Unable to connect via SSL from ACT to Aster DB using Scenario 3(Aster Client Guide 622_update 2)

Aster
Visitor

Unable to connect via SSL from ACT to Aster DB using Scenario 3(Aster Client Guide 622_update 2)

Using ACT 6.10 and Aster Express for VMWARE 6.10

Using the GUI webpage to make my changes to the Aster Queen Node - 192.168.100.100:2407/std/configflags

and

Using command line flags with ACT, see below for my syntax:

linux-5uy3:/home/jimmy/AsterClient/stage/home/beehive/clients-linux64 # ./act -U beehive -w beehive -h 192.168.100.100 --enable-ssl --ssl-self-signed-peer --ssl-certificate-path /home/jimmy/certs/client.cert --ssl-private-key-path /home/jimmy/certs/client.key --ssl-cert-filetype 1
act: ERROR:  Transport Error: Failed to setup SSL

For my Client I am using OpenSUSE(Linux linux-5uy3 4.4.27-2-default ) on VMWARE

and this is what I did:

  • create folder Ex: certs (/home/jimmy/certs)
  • change folder to certs. Ex:cd /home/jimmy/certs
  • openssl genrsa 1024 > client.key
  • chmod 400 client.key
  • openssl req -new -x509 -nodes -sha1 -days 365 -key client.key > client.cert
  • openssl x509 -in client.cert -text > client.pem
  • Copy the all the contents in /certs/ to queen node (/home/beehive/certs).

 

My Queen Settings are as follow:

  • disallowPeerWithoutCertificates=true
  • self-signed-peer=false
  • trustedCAFileName=/home/beehive/certs/client.pem
  • sslCertificatePath=/home/beehive/certs/server.cert
  • sslPrivateKeyPath=/home/beehive/certs/server.key
  • sslFileType=1 (A value of "1" means SSL_FILETYPE_PEM. A value of “2” means
  • SSL_FILETYPE_ASN1.)
  • There is no need to set the trustedCAPath parameter if you use a single root
  • certificate for all clients.
  • Ensure that secureWrites is set to false.
  • Ensure that secureMuleServer is set to true

Any help would be greatly appreciated.