Connection to Presto with Teradata ODBC from Tableau stopped working

Connectivity
N/A

Connection to Presto with Teradata ODBC from Tableau stopped working

I'm using Tableau 9.3 on a windows server.

I also have Presto for querying over Hive.

Using the Teradata ODBC connector to connect to Presto.

Presto release: 0.147

Hive version: 1.2.1

When using the Tableau Desktop to create a workbook, the connection works fine and I'm able to get data from tables correctly.

But when I publish the workbook and try to open it from a web browser (even from the server itself) I get the following error:

********************************************************************

An unexpected error occurred. If you continue to receive this error please contact your Tableau Server Administrator.

[Teradata][Presto] (1020) Error with HTTP API at <Our server name witch I deleted here> : Couldn't connect to server The table "[schema].[table_name]" does not exist. Unable to connect using the DSN named "Teradata Presto ODBC DSN". Check that the DSN exists and is a valid connection. 

2016-08-16 09:45:29.455, (V7Lf@goKATMAABL8OOEAAAIe,0,0)

********************************************************************

The table does exist and I'm able to query it from cli.

When testing the connection with Windows ODBC Data Source Administrator on the server there is a success. No errors.

For the first weeks of using this connector this did not happen, but then just started failing without any changes being made to the environment.

Another connector that I have tried did not produce this error and continues to work just fine from Tableau Desktop AND web.

Any ideas on why this is happening?