Issue with connection using RODBC to Teradata

Connectivity
Enthusiast

Issue with connection using RODBC to Teradata

I am facing this issue on Red Hat Linux Server while connecting using R onto Teradata 14.10.

I am using R-3.2.1 and Teradata 14.10 client. Also installed RODBC package.

Below is the error I am noticing:

$ R

> library(RODBC)

> db <- odbcConnect("testdsn", uid = "userid", pwd = "password")

Warning message:

In odbcDriverConnect("DSN=testdsn;UID=userid;PWD=password") :

  ODBC connection failed

> q()

Below are the contents of the odbc.ini and odbcinst.ini files:

odbc.ini contents:

[ODBC]

InstallDir=/opt/teradata/client/14.10/odbc_64

Trace=0

TraceDll=/opt/teradata/client/14.10/odbc_64/lib/odbctrac.so

TraceFile=/usr/joe/odbcusr/trace.log

TraceAutoStop=0

[ODBC Data Sources]

testdsn=tdata.so

[testdsn]

Driver=/opt/teradata/client/14.10/odbc_64/lib/tdata.so

Description=Teradata database

DBCName=<TD server IP address given>

LastUser=

Username=userid

Password=password

Database=

DefaultDatabase=

--------------------------------

odbcinst.ini contents:

[ODBC DRIVERS]

Teradata=Installed

[Teradata]

Driver=/opt/teradata/client/14.10/odbc_64/lib/tdata.so

APILevel=CORE

ConnectFunctions=YYY

DriverODBCVer=3.51

SQLLevel=1

-------------------------------------

I have also set the ODBCINI environment variable and also included the necessary path inLD_LIBRARY_PATH.

Request you to provide any suggestions on this issue. Am i missing any other settings.

1 REPLY

Re: Issue with connection using RODBC to Teradata

Did you get any resolution to this problem?