.Net framework version 2.0 3.0 3.5 must be installed before installing .Net data provider for TD. Installation aborted.

Connectivity
N/A

.Net framework version 2.0 3.0 3.5 must be installed before installing .Net data provider for TD. Installation aborted.

I have .Net framework 4.0 installed.

where do we get TD .Net data provider for 4.0 version? I don't want to downgrade my app to 3.5 or less from 4.0.

5 REPLIES
Teradata Employee

Re: .Net framework version 2.0 3.0 3.5 must be installed before installing .Net data provider for TD. Installation aborted.

The .NET Data Provider for Teradata version 13.11 supports the .NET Framework 4.0. However the Installation part of the the Data Provider requires .NET Framework 2.0 SP2, 3.0 SP2 or 3.5 SP1. You can use the .NET Data Provider 13.11 in a Private-Deplyoment configuration with your .NET Framework 4.0 application.

Re: .Net framework version 2.0 3.0 3.5 must be installed before installing .Net data provider for TD. Installation aborted.

So I have VS 2010 Professional and installed TD .NET provider today.

Once the installation completed, VS had so many extensions and startup errors.

So, what is the best way to install TD on a VS 2010.

Of course my machine has Frameworks 4.0 installed.

Some more detail is appreciated...

Teradata Employee

Re: .Net framework version 2.0 3.0 3.5 must be installed before installing .Net data provider for TD. Installation aborted.

I have VS 2008 and VS 2010 on Windows 7 with three different versions of the .NET Data Provider. I recommend you open incident.

The VS (2008 or 2010) integration is controlled through the Registry. Is VS reporting errors  for the .NET Data Provider (Teradata.Client.VS.dll) integration? or is it reporting errors about other packages you have on your workstation? You may see errors for the other packages that had previously failed to load in VS and subsequently were suppressed to load on VS startup. 

Re: .Net framework version 2.0 3.0 3.5 must be installed before installing .Net data provider for TD. Installation aborted.

Existing packages/extensions were messed up. I lost almost all of my toolbox items. Everything is disabled.

Teradata Employee

Re: .Net framework version 2.0 3.0 3.5 must be installed before installing .Net data provider for TD. Installation aborted.

The .NET Data Provider Installation adds registry keys to

  HKLM\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\10.0\DataProvider

  HKLM\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\10.0\DataSources

  HKLM\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\10.0\Packages

After adding registry keys, it starts "DevEnv.exe /setup". At this point Visual Studio takes over to add the package.  So there can be few root cause; a) Installation somehow overwrote other keys in Packages, DataProvider or DataSources registry keys or b) some other app had overwritten the registry but it was detected after "DevEnv.exe /setup".