Qlikview Failures

Connectivity

Qlikview Failures

Hi.  I'm fairly new to Qlikview and Teradata connectivity.

Using the TPT connector I can NOT make a connection at all.

Using ODBC (32 or 64) I get the dreaded:

Error: SQL##f - SqlState: IM002, ErrorCode: 0, ErrorMsg: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

Using the OLE DB wrapper on it ... same deal.

It's a show stopper, anyone have an idea to help?  Is it a permissions issue of some sort?

Thanks for any help.

2 REPLIES

Re: Qlikview Failures

New spin.  I needed to establish the ODBC on both the servers and now have:

1/14/2015 10:16:35 AM: 0018  ODBC CONNECT*

1/14/2015 10:16:35 AM:       Error: SQL##f - SqlState: IM003, ErrorCode: 160, ErrorMsg: Specified driver could not be loaded due to system error  126: The specified module could not be found. (Teradata, C:\Program Files\Teradata\Client\15.00\ODBC Driver for Teradata nt-x8664\Lib\tdata32.dll).

1/14/2015 10:16:35 AM:       General Script Error

1/14/2015 10:16:35 AM:       Execution Failed

1/14/2015 10:16:35 AM:      Execution finished.

Files are located in the locations. 

This is perplexing.

Teradata Employee

Re: Qlikview Failures

RE:

"Error: SQL##f - SqlState: IM002, ErrorCode: 0, ErrorMsg: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified"

Make sure you have created the ODBC DSN created using ODBC Administrator.  Depending on application bitness i.e., 32-bit or 64-bit you need to use ODBC Administrator of same bitness.

RE:

"1/14/2015 10:16:35 AM: Error: SQL##f - SqlState: IM003, ErrorCode: 160, ErrorMsg: Specified driver could not be loaded due to system error 126: The specified module could not be found. (Teradata, C:\Program Files\Teradata\Client\15.00\ODBC Driver for Teradata nt-x8664\Lib\tdata32.dll)."

Have you tried re-starting the application/service ?