Import Problem - Date field

Database

Import Problem - Date field

Trying to import a tab delimited file. Made sure my dates in the file at mm/dd/yyyy but I'm still getting the error. Created the field as type Date.

Any insight?
8 REPLIES
Enthusiast

Re: Import Problem - Date field

Hi Ncullen,

Make sure all the date field in the import file is in the format 'yyyy-mm-dd' and then try importing.I hope it works..
Junior Contributor

Re: Import Problem - Date field

How do you try to import it?
BTEQ/FastLoad/MLoad/TPump/SQL Assistant?

Instead of changing the format in your input file you might simply add a FORMAT in the INSERT.

Dieter
Enthusiast

Re: Import Problem - Date field

Through Fastload/Multiload/Queryman - you can able to import any format of date.
Just specify the format in the layout in case of loader utilities - or through queryman just change the date format in Options....

Re: Import Problem - Date field

Hi,

I'm trying to import excel file in teradata which contains date field.

It is showing error as wrong number of values in import file.

And also want to know how to add a format in insert query.

thanks in advance

Senior Supporter

Re: Import Problem - Date field

Which tool do you use?

Enthusiast

Re: Import Problem - Date field

Hi yamu

If ur using queryman to import,its better to copy the content from excel into a notepad/textpad and try.set delimiter optinon to {TAB} for import in queryman..Even i got the same error.wen i tried using notepad it was fine.

Re: Import Problem - Date field

Hi,

I use SQL assistant 12.0.

I tried to import notepad file. It  is working fine. Thanks.

but while importing excel file how to add a format in insert query for date field.

Enthusiast

Re: Import Problem - Date field

Hi

Make sure that the format of Date column in Target is same as the one in file you are using for Import.