Importing Data Issue

Database
Enthusiast

Importing Data Issue

Hello, this is my first post, thanks in advance for any help! I'm a bit new to Teradata.

I'm trying to import a very simple table (only 2 columns, both are numbers). Here's the process I'm going through:

 

Create a volatile table:

SyntaxEditor Code Snippet

create volatile table sept_subs (

BAN integer,num integer)

SyntaxEditor Code Snippet
insert into sept_subs (?,?)

 When I select the file to import, it does so successfully, and says it loaded 2 rows (this is a simple test file with numbers in both columns). Delimiter is comma, and I made sure comma was selected in the import settings. However, when I do a SELECT statement on the sept_subs table, it turns up 0 records.

 

The data I'm trying to import is below. Any thoughts? I've tried several times, tried different data types, and no luck...

 

BAN,MDN
123,456
789,321


Accepted Solutions
Senior Apprentice

Re: Importing Data Issue

Hi,

Your volatile table statement needs

 

ON COMMIT PRESERVE ROWS

 

at the end.

 

Cheers,

Dave

 

Ward Analytics Ltd - information in motion
www: http://www.ward-analytics.com
1 ACCEPTED SOLUTION
2 REPLIES
Senior Apprentice

Re: Importing Data Issue

Hi,

Your volatile table statement needs

 

ON COMMIT PRESERVE ROWS

 

at the end.

 

Cheers,

Dave

 

Ward Analytics Ltd - information in motion
www: http://www.ward-analytics.com
Enthusiast

Re: Importing Data Issue

Why didn't I try this forum earlier.... Thanks so much. That did the trick.