TD Express 13.0 32-bit - Sql*Assist does not install.

Database
Enthusiast

TD Express 13.0 32-bit - Sql*Assist does not install.

Interactive install states ".NET Framework 2.0 or higher required". I checked. I have .NET 2.0 SP2, 3.0, 4.0...
Anyone run into this before? How to get this install to work?