"Plastic steps" error disappears. Why?

Database
Teradata Employee

"Plastic steps" error disappears. Why?

We have an issue where a complex SQL caused the error "Insufficient memory for Plastic Steps for this request".  While testing the affects of the NOVIEWFOLD diagnostic, it was found that the error no longer shows.  Now the error cannot be reproduced, even with the diagnostic off.  According to the DBA, no database configurations have been changed since the issue arose.  

 

The question at hand is: "what can make the error no longer appear with the same SQL and same configuration?".

 

 

 

Thank you.

3 REPLIES
Teradata Employee

Re: "Plastic steps" error disappears. Why?

One posibility is that the query plan is being cached once you ran with the no viewfold option.

 

Try again several hours later and see if you hit the error again. If not try running your query as dbc with this commands running before your query:

 

DIAGNOSTIC SPOIL;
DIAGNOSTIC SPOILC;
DIAGNOSTIC NOCACHE ON FOR SESSION;

 

< Next run your query>

 

 

 

 

 

Junior Contributor

Re: "Plastic steps" error disappears. Why?

Or you slightly modify the source code, e.g. add a space, to prevent finding the Select in cche.

Teradata Employee

Re: "Plastic steps" error disappears. Why?

Hi.

 

Thanks for your response. I don't think that the plan caching is what happened.  The "plastic steps" error even showed up the first time we turned on NOVIEWFOLD.  It wasn't until days later, that the error disappeared.  Also, the SQL causing the problem will be slightly different every time it is run through the CIM application.  The structure will be identical, but the name of the table referenced will change each time.