Installed XML Services on 13.10 Linux


Installed XML Services on 13.10 Linux

Finally got the install to work with help from the documents on here.  When I try to generate a canonical schema using the SYSXML.GEN_QUERY_CANONICAL_SCHEMA procedure, i get the following error:


  U0027: Failed to create a CLI connector.

                Statement# 1, Info =0

 *** Total elapsed time was 1 second.

Here is the DB Version Info:

 *** Logon successfully completed.

 *** Teradata Database Release is

 *** Teradata Database Version is

 *** Transaction Semantics are BTET.

 *** Session Character Set Name is 'ASCII'.

My CLIv2 version is

my BTEQ version is


Tags (3)
Teradata Employee

Re: Installed XML Services on 13.10 Linux

SYSXML.GEN_QUERY_CANONICAL_SCHEMA is an xsp that needs to execute some queries to gather metadata so it can generate the XML schema. To execute this query it creates a CLI connection. This could fail for a few reasons:

  1. CLI is not installed correctly on the nodes (remember, the xsp is executing on the node, so we are not talking about CLI on your client system). Chapter 3 of the Orange Book includes a system requirements section that describes what needs to be installed on the nodes.
  2. The tdpid you used is not valid. This could be because the appropriate DNS entries are not in place on the nodes.
  3. The username/password you used are invalid. Since you are on TD13.10, you can just pass NULLs for the username/password parameters. These were required only in database versions prior to TD12.