Publish_XML_LOB fails with cli error

Extensibility
Enthusiast

Publish_XML_LOB fails with cli error

I am attempting to publish an XML document and I am getting the following error:

CALL Failed. 7504: in UDF/XSP/UDM SYSXML.PUBLISH_XML_LOB: SQLSTATE U0036: Fetch result set error, cli request error!errorcode: 3706, errorstring:Syntax error: expected something between the 'SELECT' keyword and the 'ROW' keyword.

ROW is the tag for each row of data returned. Why am I getting this error? My stylesheet in the repository looks like it has nulls between all the chars. Did it get switched to Unicode somehow?

When I select my Stylesheet from sysxml.stylesheetrepository it has weird characters at the begining for the clob. I successfully registered the schema and the stylesheet and call publish_xml_log with: CALL SYSXML.PUBLISH_XML_REF('SELECT A.TYPE_EQUIP_CODE AS TEC'

||' ,A.Work_Unit_Code AS WUC'

||' ,A.Equip_Serno AS SERNO'

||' ,A.Cage_ID AS CAGE'

||' ,A.Mfgr_Part_id AS PARTNO'

||' ,A.OOMA_Inv_DB_ID AS OOMA_INV_DBID'

||' ,A.OOMA_Inv_ID AS OOMA_INV_ID'

||' ,WBP.Position_Code AS POS'

||' ,A.Overhaul_Ind AS OVERHAUL'

||' ,ICU.Usage_Parm_Code AS USAGE_PARM'

||' ,IUP.Usage_Parm_Desc AS USAGE_PARM_DESC'

||' ,ICU.Usage_Since_Overhaul_Qty AS TSO'

||' ,ICU.Usage_Since_New_Qty AS TSN'

||' ,IUP.Engr_Unit_code AS ENG_UNIT'

||' FROM Deck_Prod_Tbls.Inventory A'

||' JOIN Deck_Prod_Utils.Inventory_SmtAcft_Filter ISAF'

||' ON A.Inv_Gnbr = ISAF.Inv_Gnbr'

||' JOIN Deck_Prod_Tbls.Inventory_Current_Usage ICU'

||' ON A.Inv_Gnbr = ICU.Inv_Gnbr'

||' LEFT OUTER JOIN Deck_Prod_Tbls.Usage_Parameter IUP'

||' ON ICU.Usage_Parm_Code = IUP.Usage_Parm_Code'

||' LEFT OUTER JOIN Deck_Prod_Base_Views.WUC_Baseline_Position WBP'

||' ON A.TYPE_EQUIP_CODE = WBP.TYPE_EQUIP_CODE'

||' AND A.WORK_UNIT_CODE = WBP.WORK_UNIT_CODE'

||' AND A.POSITION_ID =WBP.POSITION_ID'

||' LEFT OUTER JOIN Deck_Prod_Base_Views.WUC_Baseline WB'

||' ON A.TYPE_EQUIP_CODE = WB.TYPE_EQUIP_CODE'

||' AND A.WORK_UNIT_CODE = WB.WORK_UNIT_CODE'

||' WHERE A.TYPE_EQUIP_CODE = ''AMAA'''

||' AND A.Equip_Serno = ''161519'''

||' ORDER BY 1,2,3,4,5,6,7', 'Inv_Usage_Style','','S', outCLOB, outINT);

 

Tags (1)