Timestamp format issue

General
Enthusiast

Timestamp format issue

Hi All,

 I have an issue with TIMESTAMP(0) format, Here it is:

my source data format is : 09-19-2014-45:35:25 and column is defined as timestamp(0) and the format as 'MM-DD-YYYY-HH:MI:SS'.

But when i tried to load this table using , All source routed to E1 table and the reason is invalid timestamp.

09-19-2014-45:35:25('MM-DD-YYYYbHH:MI:SS'), even this is not working (used blank)

and then I changed data to 2014-09-19 45:35:25(YYYY-MM-DD HH:MI:SS),it was working fine for the same column.

I didn't understnad where did go wrong, Can someone help me on this?

Thank you!!

2 REPLIES
Junior Supporter

Re: Timestamp format issue

I cannot think of setting a date at 45:35:25 (HH:MM:SS)

 BTEQ -- Enter your SQL request or BTEQ command:

select cast('09-19-2004-45:35:25' as timestamp(0) format 'MM-DD-YYYY-HH:MI:SS');

 *** Failure 6760 Invalid timestamp.

                Statement# 1, Info =0

 *** Total elapsed time was 1 second.

 BTEQ -- Enter your SQL request or BTEQ command:

select cast('09-19-2004-15:35:25' as timestamp(0) format 'MM-DD-YYYY-HH:MI:SS');

 *** Query completed. One row found. One column returned.

 *** Total elapsed time was 1 second.

'09-19-2004-15:35:25'

---------------------

  09-19-2004-15:35:25

Cheers

Carlos.

Enthusiast

Re: Timestamp format issue

Oops..that was Typo mistake.

thanks for your reply ..even I tried the same in SQL assistant before posting this topic in forum, It worked out. 

But when we run through our process it was failing, So I thought may be any other option.

Now, I came to know issue is not with Teradata formats, Issue is with our application predefined timestamp formats, it doesn't support the above format.

 Thank you.