select command using BTEQ is not returning all fields

General
Enthusiast

select command using BTEQ is not returning all fields

Good morning:

i need your help: i've got 2 questions:

the first one is:
i use bteq to connect to Teradata and i want to select the first 5 records of a table but returned just 2 columns.

select top 5 * from DWH_LOG.procesos where nom_proceso = 'wedo_sqntbalanceexpire';

*** Query completed. One row found. 8 columns returned.
*** Total elapsed time was 1 second.

Num_proceso Nom_proceso
----------- ---------------------------------------------------------------
119 wedo_sqntbalanceexpire

BTEQ -- Enter your DBC/SQL request or BTEQ command:

but the table has 8 colums as you can see below:

Column Name Type Comment
------------------------------ ---- ---------------------------------------
Num_proceso I ?
Nom_proceso CV ?
Fec_proceso TS ?
Periodicidad CV ?
Prefijo_planos CV ?
Tiempo_Estimado I ?
FecUltimoCorteDatos TS ?
Status CV ?

you know the * means all the columns. isnt it? what can i do to return all columns in the query?

2nd - is there any command to show me which databases and tables a database user has access and what kind of permissions. i.e select - insert permissions?

id appreciate your help, thanks
2 REPLIES
Enthusiast

Re: select command using BTEQ is not returning all fields

Something to say? Add your comment here.
Enthusiast

Re: select command using BTEQ is not returning all fields

The answer to your first question is that BTEQ truncates the displayed output lines according to your output width setting, which is 75 characters by default. use the ".SET WIDTH" command to increase it.

Alternatively, you can use the ".SET FOLDLINE" command to split each result row into multiple report lines.