What do I need to install on a MAC to get studio or studio express working?

Teradata AppCenter
AppCenter is a framework to build, share, deploy and consume big data apps for self-service analytics and discovery for the business community.
Highlighted
Teradata Employee

Re: What do I need to install on a MAC to get studio or studio express working?

The -vm override must precede -vmargs keyword:

-startup
../Eclipse/plugins/org.eclipse.equinox.launcher_1.3.200.v20160318-1642.jar
--launcher.library
../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.400.v20160518-1444
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_172.jdk/Contents/Home/bin/javaw.exe
-vmargs
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Dosgi.requiredJavaVersion=1.8
-Xms512m
-Xmx512m
-Djava.util.Arrays.useLegacyMergeSort=true

Re: What do I need to install on a MAC to get studio or studio express working?

By placing the -vm lines above the -vmargs lines and replacing javaw.exe by java , I managed to start up Teradata Studio!

For future reference, here is the full working content of TeradataStudio.ini:

-startup
../Eclipse/plugins/org.eclipse.equinox.launcher_1.3.200.v20160318-1642.jar
--launcher.library
../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.400.v20160518-1444
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_172.jdk/Contents/Home/bin/java
-vmargs
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Dosgi.requiredJavaVersion=1.8
-Xms512m
-Xmx512m
-Djava.util.Arrays.useLegacyMergeSort=true

Thank you for the fast response Fred. It would be great to add some guidance around where to find the TeradataStudio.ini file on macOS and how to specify which Java version to use to the installation guide: it currently only explains the process for Windows.