SQL Assistant - Answerset showing VARCHAR columns as CLOB

Teradata Applications

SQL Assistant - Answerset showing VARCHAR columns as CLOB

I'm trying to run a simple SELECT in SQL Assistant 16.10 from a normal table:

 

CREATE TABLE Contract (
ContractId INTEGER NOT NULL PRIMARY KEY,
ContractStartTS TIMESTAMPTZ NOT NULL,
ContractEndTS TIMESTAMPTZ NOT NULL,
RevisionDeadlineTS TIMESTAMPTZ NOT NULL,
RewardNotes VARCHAR(500),
StudentLeaderRequirements VARCHAR(500),
TeacherRequirements VARCHAR(500),
StudentRequirements VARCHAR(500)
);

 

It returns the VARCHAR fields as CLOBs, which is not what I want.  I already set the "Handle Varchar Columns as CLOBS if size > _____ " value to 10,000.  But SQLA still shows the varchar fields as CLOBs.  How do I fix this?

 

This is from a Postgres 9.6 database connected via ODBC.  Thanks.

 

Chris Khosravi

2017-10-05 17_28_11-Advanced Options (PG dcp) 1_3.png2017-10-05 17_28_17-Advanced Options (PG dcp) 2_3.png2017-10-05 17_28_20-Advanced Options (PG dcp) 3_3.png2017-10-05 17_27_38-Teradata SQL Assistant (PG dcp).png2017-10-05 17_27_54-Options.png

 

Tags (3)

Accepted Solutions
Teradata Employee

Re: SQL Assistant - Answerset showing VARCHAR columns as CLOB

On the Advanced Options Page 1/3 the setting for Max Varchar is 255.

I suspect that means it will treat all larger strings as CLOBs.

 

If that is not the issue there is a workaround:

When it displays the LOB Information dialog you can click Cancel.

That will cause it to treat the data as a Varchar. (similar for BLOB/Varbyte)

1 ACCEPTED SOLUTION
2 REPLIES
Teradata Employee

Re: SQL Assistant - Answerset showing VARCHAR columns as CLOB

On the Advanced Options Page 1/3 the setting for Max Varchar is 255.

I suspect that means it will treat all larger strings as CLOBs.

 

If that is not the issue there is a workaround:

When it displays the LOB Information dialog you can click Cancel.

That will cause it to treat the data as a Varchar. (similar for BLOB/Varbyte)

Highlighted

Re: SQL Assistant - Answerset showing VARCHAR columns as CLOB

Yep, changing that MaxVarChar setting to 64000 did the trick.  I love SQL Assistant.  Thanks Mike!