Terdata VmWare Developer version Deployment

Teradata Database on VMWare
Highlighted
Teradata Employee

Terdata VmWare Developer version Deployment

Hi

I am trying to deploy Teradata 16.20 developer version, using vmWare ESXi and VCenter 6.5 trial version. I am using Power shell script. The underlying server is Dell T630. All my configurations go well, till the point where script updates DBS flags. At this point script fails giving the below error:

 

*****

[ Wed May 2 11:16:15 EDT 2018 ] - key=fsgCache and value=40
[ Wed May 2 11:16:15 EDT 2018 ] - disableIPE=false
[ Wed May 2 11:16:15 EDT 2018 ] - key=disableIPE and value=false
[ Wed May 2 11:16:15 EDT 2018 ] - DB_MAJOR_VERSION=16.20
Changing Block Level Compression and PermDBSize - /usr/pde/bin/cnsrun -utility dbscontrol -output -commands "{m co 10 = on} {m f 3 = 2047} {wr} {q}"

cnsrun: fatal error CNS Connection Lost.
[ Wed May 2 11:16:15 EDT 2018 ] - Changing Block Level Compression and PermDBSize on VM failed with command error - 2

5/2/2018 12:16:31 PM Status of step:
Error: Failed to set DBS flags. Please check the output and the logs located in /root/tvme/ to verify inputs are correct.
WARNING: The version of VMware Tools on VM 'TDDBS' is out of date and may cause Copy-VMGuestFile to work improperly.

Deployment started - 5/2/2018 12:12:22 PM
Deployment finished - 5/2/2018 12:16:34 PM
**********************
Windows PowerShell transcript end
End time: 20180502121634
**********************

*****

So apparently it is unable to update the DBS flags of BLC and PermDBSize. I am unable to figure out as how to fix this. Tried running a multiple times, but result is same. Can anyone help me with it.

5 REPLIES
Teradata Employee

Re: Terdata VmWare Developer version Deployment

Take a look at the files under /root/tvme to see if there are any clues. Also if you want to attach your property files, and deployment log from the logs subdirectory from where you ran the deployment that might help.

Teradata Employee

Re: Terdata VmWare Developer version Deployment

Hi Arnie

Thanks for the input. Yes, I did check the files in /root/tvme/. There are 3 json files, 2 are node and common properties and the other is state.json, but none of these are giving any clue about why is script failing to set DBS flags. Apart from that there are time zone settings files (Temporal, Linux time zone) which are not of much help. Let me share with you the deployment logs and property files over email. 

Teradata Employee

Re: Terdata VmWare Developer version Deployment

I reviewed the property  files, deploymennt logs and I am also checking with enginering. I noticed in the deployment log there was a message that the image already exists. Just wanted to confirm that you have tried deleting the the bad image before you are redeploying? One suspicion I have is that maybe it is related to deploying on Vcenter 6.5. If you have a VCenter 6.0 or 5.5 and the same corresponding ESXi version try deploying in that environment. The original development work was not done with 6.5 and I have seen some strange errors go away when people redeployed with 6.0 and 5.5.

Teradata Employee

Re: Terdata VmWare Developer version Deployment

Considering that the scripts are re-entrant, I didn't delete the bad image before redeploying and tried everytime for the same image. I will try deleting the image and re-deploy now. As for the version, we have vCenter 6.5 configured on a shared server, which is hosting other VMs too. So it would not be possible for me to downgrade the version of vCenter. I was assuming that TDVM is compatible with 5.5+ versions. Please do share if we get any update from engineering. 

Teradata Employee

Re: Terdata VmWare Developer version Deployment

Just an update. 

i changed the image and downgraded it from 16.20 to 16.10, used the below properties files and this time script completed its execution successfully. TPA node with 16.10 is configured successfully. I will be trying again with 16.20 to see if it works too. 

 

Common Properties; 

{
"TDsystemname": "TPA",
"domain": "td.teradata.com",
"public_vswitch": "VM Network",
"byn_vswitch1": "",
"byn_vswitch2": "",
"cmic_vswitch1": "",
"cmic_vswitch2": "",
"dsu_vswitch": "",
"public_submask": "255.255.255.128",
"gateway": "153.65.x.x",
"dns1": "153.65.x.x",
"dns2": "153.65.x.x",
"ntp1": "utcnist.colorado.edu",
"ntp2": "",
"OSTimeZone": "US/Pacific",
"pdiskSizeGB": "100",
"Temporal": "FALSE",
"TemporalDaylightSavings": "FALSE",
"TemporalTimeDateWZControl": 0,
"TemporalTimeZoneHour": 0,
"TemporalTimeZoneMinute": 0,
"TemporalTimeZoneString": "America Pacific",
"SecureZones": "FALSE",
"RowLevelSecurity": "FALSE",
"Columnar": "FALSE",
"MainframeLHID":"-1",
"SiteID": "",
"Folder":"",
"IPAddressSetting":"dhcp"
}

 

Node Properties; 

[
{
"ESXiHost": "153.65.x.x",
"OS_Datastore": "datastore1",
"vmName": "TPA",
"vmType": "tpa",
"Template": "Teradata_Database_16.10.00.03_SLES11_SP3_on_VMware_20170823124016"
}

]