Need help with Java Version:

Teradata Studio

Need help with Java Version:

I installed Teradata Studio and I have Java jre6, jre7 and jre1.8. When I installed it, I changed the java to jre6. When I ran it I get an error, error window pops up:

JAva was started but returned exit code=1

C:\Program Files\Java\jre6\bin\javaw.exe

.... and so forth.

Need assitance.

Thanks

Chris

4 REPLIES
Teradata Employee

Re: Need help with Java Version:

Chris, Can you verify that you have the correct bit version of Teradata Studio that matches the JRE, either 32-bit for both or 64-bit for both? If you open a DOS window and run the command:

java -version

It will show you the JRE version.

Re: Need help with Java Version:

I don't know about Chris, but I'm having the same problem.

I've installed TeradataStudioExpress 15.00 from TeradataStudioExpress__win64_x86.15.00.02.00.zip on Windows 7 Professional.  I'm running Java 1.7

C:\Users\sosha>java -d64 -version

java version "1.7.0_55"

Java(TM) SE Runtime Environment (build 1.7.0_55-b13)

Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)

After a second or two of Teradata Studio Express starting I get a popup the starts, "Java was started but returned exit code=1"

There is an error logfile  in C:\Program Files\Teradata\Client\15.00\Teradata Studio Express nt-x8664 named hs_err_pid6352.log that starts with, 

#

# A fatal error has been detected by the Java Runtime Environment:

#

#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000076fd32f2, pid=6352, tid=3800

#

# JRE version: Java(TM) SE Runtime Environment (7.0_55-b13) (build 1.7.0_55-b13)

# Java VM: Java HotSpot(TM) 64-Bit Server VM (24.55-b03 mixed mode windows-amd64 compressed oops)

# Problematic frame:

# C  [ntdll.dll+0x532f2]

#


---------------  T H R E A D  ---------------

Current thread (0x000000000221f800):  JavaThread "main" [_thread_in_Java, id=3800, stack(0x0000000002630000,0x0000000002730000)]

siginfo: ExceptionCode=0xc0000005, writing address 0x0000000000000002



Teradata Employee

Re: Need help with Java Version:

Steve, We haven't seen this error before but when I googled the error message, most responses indicated a problem with your graphic card, but I would first try installing another version of the JRE. 

Re: Need help with Java Version:

Wow.  That was easy. Thanks!  I already had 1.7.0_60 installed.  But JAVA_HOME was still pointing to 1.7.0_55.  A quick edit and I'm in business.

I hope learning to work with Teradata is as easy.

Thanks Francine,

Steve O