Studio Express Smart Loader error

Teradata Studio
Teradata Employee

Studio Express Smart Loader error

I just upgraded to StudioX 15 and I received a JRE update to 7 update 65. I'm getting errors when trying to load a table through the Data Lab smart loader. I'm able to create my table, but the load statement fails with a message of:

!ENTRY org.eclipse.core.jobs 4 2 2014-07-31 16:26:34.124

!MESSAGE An internal error occurred during: "Load Data Orders_data_Final".

!STACK 0

java.lang.NullPointerException

    at com.teradata.datatools.dtp.ddl.TeradataDdlBuilder.getName(TeradataDdlBuilder.java:1646)

    at org.eclipse.datatools.connectivity.sqm.core.rte.fe.GenericDdlBuilder.dropTable(GenericDdlBuilder.java:203)

    at com.teradata.datatools.dtp.ddl.TeradataDdlGenerator.dropStatements(TeradataDdlGenerator.java:1165)

    at com.teradata.datatools.dtp.ddl.TeradataDdlGenerator.dropSQLObjects(TeradataDdlGenerator.java:307)

    at com.teradata.datatools.dtp.datalab.model.SmartLoaderTableModel.dropTable(SmartLoaderTableModel.java:410)

    at com.teradata.datatools.dtp.datalab.wizards.SmartTableWizard$2.handleError(SmartTableWizard.java:159)

    at com.teradata.datatools.dtp.fastload.model.FastLoadModel$1.run(FastLoadModel.java:295)

    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

I have tried multiple files, receiving the same error. I have uninstalled, blown away my workspace in my user profile - to no avail.

I also notice that the population of the data lab objects is very slow for one of the systems I access. This one has multiple lab groups and data labs - takes upward of five minutes. The other system with 10 lab groups is complete within about 30 seconds.

The system with many objects is running 13.10 (but datalabs/vp 15) where the quicker one is running 14.00 with vp and data labs both at 14.01

Thanks,

Bob

4 REPLIES
Teradata Employee

Re: Studio Express Smart Loader error

Robert, We have not seen this issue so will try to recreate the problem. Is there anything special about the data you are trying to load? Is it loading from delimited text or .xlsx file, encoding, comma and character delimiters? Is the issue happening in both of your systems, 13.10 and 14.00?

Teradata Employee

Re: Studio Express Smart Loader error

I've tested .csv and .xlsx - it's happening with both systems. I also tried Studio, same error. But, in Studio I can do a data transfer of a table from one system to another system.

Teradata Employee

Re: Studio Express Smart Loader error

Anything different about the data you are loading? Have you tried other files to smart load or it happens with all smart loads to the data lab? Does it happen if you smart load to a database outside the data lab? thanks.

Teradata Employee

Re: Studio Express Smart Loader error

All smart loads. Same error, either system.

I did the data transfer load from the 13.10 DB to 14.00 DB and that worked with no issue.....