Teradata Studio Express laggy on Mac

Teradata Studio

Teradata Studio Express laggy on Mac

Teradata studio express is very slow on my Mac.  I’ve checked other threads and think I’ve done all the same steps to address it.  

Symptoms include :

1. Lag when typing or scrolling

2. Delay (up to 20 seconds) in execution of queries from the time I hit the ‘execute’ button, that is it doesn’t even start to try executing for 20 seconds or so. And once executing is erratic in response time for the same query

3. Starts getting noticeably slow within about  30 minutes.

Things I’ve tried :

1. Turned off Code Assist Autoactivation

2. Keep only a few results tabs open at a time

3. limit to 2K or ‘sample 10’ to keep result sizes low

4. Added the following to /Applications/TeradataStudioExpress/configuration/config.ini (started lower increased in 1 gig increments, seems to help but just prolongs the issue)

-vmargs

-Xms2048m

-Xmx4096m

-XX:PermSize=512m

-XX:MaxPermSize=1024m

5. turn off 'enable syntax validation'

6. Reduce history size from 200 to 50

My Specs :

OSX 10.10.3

2.2 Ghz intel core i7

16 G ram

Teradata Studio Express 15.10.0

My queries haven’t been that large or complicated, typically involving around 5 tables. I’ve typically created a handful of volatile tables of size less than 10K rows.  Once the issue starts I have to reconnect to clear it up.  Does anyone have any other insights?

thanks

Sean

6 REPLIES

Re: Teradata Studio Express laggy on Mac

It's the same for me, I've have tried the same and the problem persists.

Re: Teradata Studio Express laggy on Mac

I also have this issue. Any progress on a solution?

Teradata Employee

Re: Teradata Studio Express laggy on Mac

We have seen a lot of complaints on the web for Eclipse slow performance on Mac. Suggestions include the usual vm args, and using a JVM later than 5.0. We will continue to look for a solution to this issue.

Re: Teradata Studio Express laggy on Mac

Thanks for the prompt response, fgrimmer. To clarify, "the usual vm args" are

-vmargs

-Xms2048m

-Xmx4096m

-XX:PermSize=512m

-XX:MaxPermSize=1024m

This looks different than the rest of the parameters in config.ini file. Is there a place we should put it in the file?

Teradata Employee

Re: Teradata Studio Express laggy on Mac

For Teradata Studio, they should go in the TeradataStudio.ini file that is in your install directory. The vmargs by default look like this:

-vmargs

-Dosgi.requiredJavaVersion=1.6

-Xms512m

-Xmx512m

-XX:MaxPermSize=512m

-Djava.util.Arrays.useLegacyMergeSort=true

Similarly for Studio Express, there is a TeradataStudioExpress.ini.

Teradata Employee

Re: Teradata Studio Express laggy on Mac

We have noticed an issue with Teradata Studio on Mac OSx when installed remotely by the administrator. The user did not have Administrator premission and thus an administrator had to log in remotely to install Studio on his Mac machine. The user noticed the slow response and posted the following:



"I ended up uninstalling and reinstalling.  I believe something got messed up during the install.  I am not sure what happened, but at the time, I did not have Admin rights on my laptop/Mac.  My install was done remotely over VPN and Webex, and I am not sure if some configuration files or Workspace files may have been set for a shared drive or something.

It is early yet, but Studio is responding much better now and the issue seems to have gone away.  I do need to use it longer to be sure, but that will come.  I increased the parameters in the .ini file as well.  It may be a good idea to document that process of unlocking the directory and files on the Mac Finder and updating the file.  This is definitely not intuitive on the Mac."



Not sure if this is your situation?



Another option we to check the Java Control Panel system preference and the Temporary Internet Files setting for Java. Change the setting from 32GB to 5 GB and use "Delete files..." for the Trace and Log Files and Cached Application and Applets.