Teradata Studio query returned 0 rows but SQLA returned 1,027 rows...identical query.

Teradata Studio
Enthusiast

Teradata Studio query returned 0 rows but SQLA returned 1,027 rows...identical query.

I submitted the identical query in Teradata Studio (Version: 15.00.00.201407291521) and SQL Assistant (Version 14.10.0.08). In Teradata Studio, 0 rows returned but SQLA returned 1,027 rows. Is there a setting that will prevent rows from returning?

2 REPLIES
Senior Apprentice

Re: Teradata Studio query returned 0 rows but SQLA returned 1,027 rows...identical query.

There's probably a simple solution.

Are there any string comparisons in your query?

Your system probably defaults to Teradata session mode (BEGIN/END TRANSACTION or BT/ET), but Studio uses ANSI mode (COMMIT).

Check this article: Transitioning from SQL Assistant to Studio Express

NOTE: In Studio Express, the default Teradata Mode (TMODE) is set to ANSI and the default TMODE setting with SQL Assistant is TERA. As the recommended TMODE setting is ANSI, users can change the TMODE to TERA. To change the TMODE property, press the Add button and select the property TMODE. Choose the property value TERA and click OK to replace the existing TMODE property. Please refer to the Teradata Documentation (SQL Request and Transaction Processing) for differences between Teradata and ANSI Session Modes. One particular difference is that by default, character comparisons are always CASESPECIFIC in ANSI session mode, where character comparisons are always NOT CASESPECIFIC in Teradata session mode.


Enthusiast

Re: Teradata Studio query returned 0 rows but SQLA returned 1,027 rows...identical query.

Changing TMODE=TERA returned rows. Thank you for the quick response!