Teradata Studio set favourite db/autocompletion

Teradata Studio

Teradata Studio set favourite db/autocompletion

After connecting to our dwh I have to go down several tree's to reach my desired locations in the data source explorer.

 

Is it possible to set a favourite database from our dwh in the studio? 

 

Autocompletion is also not working in the studio, I can't find any suggestions for tables and also no suggestions for columns when im typing, for example:

 

sel * from db.test t where t.

 

I would hope to get column suggestions after I type the . from the defined table, here db.test.

 

Is this possible to achieve this in the teradata studio? I imagine it does not work because of the overload of databases?

 

Appreciate any help, thank you.


Accepted Solutions
Teradata Employee

Re: Teradata Studio set favourite db/autocompletion

Content assist uses the database metadata to determine what objects to provide in the drop down list or next in the syntax. You could cache the databases you are interested in so that loading is done from the cache instead of going to the database.

Also, when you enter a database name, then enter <dot>, content assist will try to return all possibilities, this includes tables, views, macros, procedures, etc. You can disable the folders (or objects) you are not interested in to speed this up. There is a Data Source Explorer Load Preference page where you can uncheck the folders you are not interested in. (Note, the loading of UDFs does take longer than other objects). This should reduce the time for content assist.

1 ACCEPTED SOLUTION
6 REPLIES
N/A

Re: Teradata Studio set favourite db/autocompletion

#1: Teradata Studio Express 15.10 now available describes how to specify the list of databases displayed.

 

#2: And you need to enable "Code Assist" in the Studio properties and to increase speed there's a "Cache Properties" button in the JDBC Connectin Properties.

Re: Teradata Studio set favourite db/autocompletion

Thank you very much for your suggestions,

 

User Choice (includes DBC) is greyed out for me to select.

 

ts.PNG

I'm using Version: 15.11.0.201605311155.

 

EDIT: I just had to uncheck 'Show Databases and Users in Hierachical Display' which makes more then sense, it works now thank you very much! 

 

I just enabled the cache property but I still don't get suggestions, will play around with it, thank you!

 

EDIT: I do get suggestions for Tables but not for columns after the changes, is there a way to get those?

Teradata Employee

Re: Teradata Studio set favourite db/autocompletion

To see the list of columns for a table, you need to qualify with the <databasename>.<tablename> then <dot>.

Re: Teradata Studio set favourite db/autocompletion

<databasename>.<tablename> then <dot> , does work, thank you!

 

But no other way to define the table with as and get suggestions? 

 

To be honest this kind of autocompletion is no real help as waiting for table suggestion, selecting table, waiting for columns, selecting column takes more time then typing out even if I misspell the column once - is there a way to speed up the suggestions atleast?

 

Teradata Employee

Re: Teradata Studio set favourite db/autocompletion

Content assist uses the database metadata to determine what objects to provide in the drop down list or next in the syntax. You could cache the databases you are interested in so that loading is done from the cache instead of going to the database.

Also, when you enter a database name, then enter <dot>, content assist will try to return all possibilities, this includes tables, views, macros, procedures, etc. You can disable the folders (or objects) you are not interested in to speed this up. There is a Data Source Explorer Load Preference page where you can uncheck the folders you are not interested in. (Note, the loading of UDFs does take longer than other objects). This should reduce the time for content assist.

Re: Teradata Studio set favourite db/autocompletion

Okay, I adjusted the settings.

Afaik the Teradata Assistant can autocomplete columns after an as definition is given so I had to ask if this is possible with the Teradata Studio.

 

Thank you very much for your help!