Teradata Studio slows down after time in the same script

Teradata Studio
Enthusiast

Teradata Studio slows down after time in the same script

When I'm working in the same script for some time ( ~20 minutes ), Teradata Studio beginns to slow down a lot. Typing has a big delay but browsing with the cursor/copy pasting is still normal. I can close/open the script and everything is fine again, I think when to many calls are associated to the same connection everything slows down. Probably I have to assign more cache to the Studio, but how?

 

As this is very unexpected, as all computations are run in the db, I'm curious what is going wrong?

 

Appreciate any help, thanks.

3 REPLIES
Teradata Employee

Re: Teradata Studio slows down after time in the same script

What version are you running? We fixed an issue in Studio 15.12 that had to do with word highlighting when you double clicked within the SQL Editor.  Could this be the same issue you are experiencing? If you close the SQL Editor and reopen, the performance should be back to normal.

Enthusiast

Re: Teradata Studio slows down after time in the same script

We are running Teradata Studio 15.11 and I'm afraid we can't update the software for now.

 

Hm, I don't think this is related to word highliting, it's the typing - for some of my collegues there is a delay of several seconds when writing in the editor. It occures minutes after opening the script so closing is not really a solution to this problem.

 

 

Teradata Employee

Re: Teradata Studio slows down after time in the same script

The delay may be from code assist option with a large database. When you pause in the SQL Editor, it is attempting to discover the next word in the SQL syntax. It uses the SQL object model and loads the information from the data dictionary. You can turn this off in top level SQL menu by toggling off the 'Code Assist Autoactivation' option. There is alsothe preference to turn off syntax validation (go to Window>Preferences>Data Management>SQL Development>SQL Editor). Uncheck the 'Enable syntax validation'.