results displaying in scientific notation - how to change

Teradata Studio

results displaying in scientific notation - how to change

I am using Teradata Studio Express to query a table.  Some results in my table are displaying as OE+9 instead of the real value.  My colleague is using Teradata Studio and her results display the real value.  How can I get my results to display the real values in Teradata Studio Express?


Accepted Solutions
Teradata Employee

Re: results displaying in scientific notation - how to change

Both Studio and Studio Express will display the large integer values as returned from the database. If you indicate you want1000s separator (Result Set Viewer preference) it will format the integer for display. Let me know if that helps. In our 16.00 release, we have added additional Result Set Viewer preferences for the number of fractional digits, which will also format the integer for display.

1 ACCEPTED SOLUTION
2 REPLIES
Teradata Employee

Re: results displaying in scientific notation - how to change

Both Studio and Studio Express will display the large integer values as returned from the database. If you indicate you want1000s separator (Result Set Viewer preference) it will format the integer for display. Let me know if that helps. In our 16.00 release, we have added additional Result Set Viewer preferences for the number of fractional digits, which will also format the integer for display.

Re: results displaying in scientific notation - how to change

Thank you!  Checking the "Display 1000 Separator in Numeric Columns" box changed the value from "OE+9" to 0.000000000 .  I would not have realized this setting was impacting the results display like this without your help!