unable to import flatfile

Teradata Studio
Enthusiast

unable to import flatfile

Hello

I use the VMWare machine TDExpress15.0.0.8_Sles10_40GB. With a previous version (TDExpress14.0.3_Sles10_40GB) I was able to import a flat file into a table with the Teradata Studio Express (table -> rightmouse -> data -> load data).

Now (Teradata 15 with Teradata Studio Express 15) this seems not to work anymore. I get no error, but there are no records loaded into my table.

I use the same text file, and the same table definition.

Has anyone experience with this ?

Thanks in advance,

Best Regards,

André.

6 REPLIES
Teradata Employee

Re: unable to import flatfile

Andre, With Teraedata Studio Express 15.00, the data load job status is stored in the Transfer History Viewer. To open the Transfer History View, go to Window>Show View and select the Transfer History View. Select the entry and click the Job Detail toolbar to see the job status. Does your input file contain dates? There was a change to be more restrictive on date input formats during load which may be the difference. We are looking to ease this restriction in our release.

Enthusiast

Re: unable to import flatfile

Hello Francine,

Thank you for your answer.

I do not have date fields in the table, only seven varchar fields, and one integer.

I notice the following:

The JDBC connection properties has charset=UTF8

- When I use (at the Load data Wizard) file encoding UTF-8, I get 'Failed', but there is no explanation why.

- When I use (at the Load data Wizard) file encoding UTF-16, It says 'Completed' but Rows Transferred is 0.

Further settings:

- File type: Delimited text

- column labels in first row

- column delimiter: Comma

- character string delimiter: None

Thanks in advance,

Regards, André.

Teradata Employee

Re: unable to import flatfile

Andre, Can you display the job details text? It is an option in the Transfer Hsitory view toolbar.

Enthusiast

Re: unable to import flatfile

Ah, I didn't notice these details before.

In the 'Failed' log row it says:

Row number 2 had an error.

Cause = com.teradata.datatools.dtp.util.data.DataFormatException: Bad data format for data type INTEGER in the column named val.;

It gives this error on all rows. All rows have just 1 as the value. As this integer is the last field, all txt rows end like this: ,1

Is this not a good format ?

Teradata Employee

Re: unable to import flatfile

Andre, We think the problem is that you are trying to load a file that was created on Windows and contains the Windows line separator (CR/LF). Studio Load feature uses the Operating System line separator (which for Linux is just LF). Thus when trying to read in the last integer in your file, it is picking up the CR and giving a DataFormat exception. One thing you can do is remove any hidden Windows line separator characters from the file using the utility called dos2unix (http://sourceforge.net/projects/dos2unix/). Then try again to load using Studio.  By the way, we are fixing this issue in our next release of Studio. 

Enthusiast

Re: unable to import flatfile

After the conversion, it is working !

Thank you for your help.

Maybe interesting for the Development department: In version 14 this problem was not occuring.

Best Regards, Andre.