ARCMAIN - UPWARD - DOWNWARD COMPATIBILITY

Tools & Utilities
Junior Supporter

ARCMAIN - UPWARD - DOWNWARD COMPATIBILITY

I have 2 teradata env. one at R13.10 and one at R15.10.

I archived a 13.10 database with Arcmain 13.10. Failed when trying to restore the arc using Arcmain 13.10 into the 15.10 env.  So, am I correct when assuming the issue is the upward compatibility of Arcmain 13.10? If so, then my approach should be to arc the 13.10 database using Arcmain 15.10 and then restore into the 15.10 env.  Correct ?

 

thanks


Accepted Solutions
rjg
Supporter

Re: ARCMAIN - UPWARD - DOWNWARD COMPATIBILITY

TTU is compatible 2 forward, current + 4 back 

So your second approach should work.

Compatibility Matrix is available from you CSR

Rglass

1 ACCEPTED SOLUTION
2 REPLIES
rjg
Supporter

Re: ARCMAIN - UPWARD - DOWNWARD COMPATIBILITY

TTU is compatible 2 forward, current + 4 back 

So your second approach should work.

Compatibility Matrix is available from you CSR

Rglass

Teradata Employee

Re: ARCMAIN - UPWARD - DOWNWARD COMPATIBILITY

FYI, ARC is the exception to the two forward + four back rule ie. ARC is not forward compatible

 

- all compatibility matrices should have a note stating this (some less obvious than others)

 

In the use case described the standard options would be;

  1. backup RDBMS 13.10 with ARC 13.10 and restore to RDBMS 15.10 with ARC 15.10
  2. backup RDBMS 13.10 with ARC 15.10 and restore to RDBMS 15.10 with ARC 15.10

 

nb. in most cases ARC is not considered a core TTU component ie. it is a part of the Tape Management Suite

 

 

ta'