BTEQ login problem

Tools & Utilities

BTEQ login problem

Hi everyone:

I downloaded teradata, configured everything, did a small application with C%.NET and successfully connected to a database I created. However I cant logon with BTEQ, using the same password. I looked online for instructions, I did everything I read but nothing...

I tried this:
Copyright 1984-2007, NCR Corporation. ALL RIGHTS RESERVED.
Enter your logon or BTEQ command:
*** CLI error: MTDP: EM_NOHOST(224): name not in HOSTS file or names database.

*** Return code from CLI is: 224
*** Error: Logon failed!

*** Total elapsed time was 23 seconds.

Teradata BTEQ for WIN32. Enter your logon or BTEQ command:

but nothing, I tried several other things but nothing either... what could I be doing wrong?

(the server is started as I can access data by a .NET application)

Thank you


Re: BTEQ login problem

by the way, I tried with that user that I have created and I tried with other built in users, the response is always the same...

Anyway, is there any built in default user like the oracle "scott/tiger"?

Any help is welcome

Thank you very much

Re: BTEQ login problem

Its solved... sorry...

just tried .logon then password and the miracle happend... I guess you can really can loose time with silly problems...
Teradata Employee

Re: BTEQ login problem


You need to add user's entry in hosts file. You can follow these steps to do so:

- Open "C:\WINDOWS\system32\drivers\etc\hosts" file in any text editor (Notepad etc.)
- Add this new line in it " localhost cop1" e.g. for DBC user it will be " localhost dbccop1" (take backup of the hosts file before changing it)
- Save the hosts file
- Open BTEQ, and use following command (suppose we have dbc username with dbc password) to login:
- ".LOGON dbc" press enter
- Enter password "dbc" press enter

And you should be in. :)




Re: BTEQ login problem

both ways it worked