Error during Teradata Plug-in for Eclipse Installation

Tools & Utilities

Error during Teradata Plug-in for Eclipse Installation

Hello,

I'm having trouble with the following error while attempting to install the TD plugin for Eclipse.   Any Ideas for finding a resolution?  

Interacting with TD version 13.10 on windows XP.

Thanks,

-Bob

Cannot complete the install because one or more required items could not be found.

Software currently installed: Teradata Plug-in for Eclipse 14.1.0.201206111039 (com.teradata.datatools.pluginFeature.feature.group 14.1.0.201206111039)

Missing requirement: Teradata Stored Procedure Java Bean Wrapper Wizard 14.1.0.201206111039 (com.teradata.datatools.javabean 14.1.0.201206111039) requires 'package org.eclipse.jst.ws.internal.consumption.ui.widgets 0.0.0' but it could not be found

Cannot satisfy dependency:

From: Teradata Java Development Feature 14.1.0.201206111039 (com.teradata.datatools.javadevelopmentFeature.feature.group 14.1.0.201206111039)

To: com.teradata.datatools.javabean [14.1.0.201206111039]

Cannot satisfy dependency:

From: Teradata Plug-in for Eclipse 14.1.0.201206111039 (com.teradata.datatools.pluginFeature.feature.group 14.1.0.201206111039)

To: com.teradata.datatools.javadevelopmentFeature.feature.group [14.1.0.201206111039]

2 REPLIES
Teradata Employee

Re: Error during Teradata Plug-in for Eclipse Installation

@forresr2 The Teradata Plug-in for Eclipse has some dependencies that aren't in the basic Eclipse package. The Installation Guide (found on the same page as the plug-in's download) explains what Eclipse package needs to be used. Basically, it says that the plug-in depends on the Eclipse IDE for Java JEE Developers package. That Eclipse package includes the necessary additional features (DTP, EMF, GEF, and WTP). In particular, the error you are seeing appears to be a result of not having the WTP feature installed.

Re: Error during Teradata Plug-in for Eclipse Installation

This happens when you try to install the eclipse plugin in SE.  You have to use Enterprise Edition.  I tried with both and it worked with EE and got this exact same error with SE.  Download and install the correct version explained in http://developer.teradata.com/tools/articles/getting-started-with-teradata-plug-in-for-eclipse