How to install Teradata Eclipse plugin on MyEclipse7.5?

Tools & Utilities
Highlighted
N/A

How to install Teradata Eclipse plugin on MyEclipse7.5?

All,

I tried installing Teradata Eclipse Plugin on MyEclipse7.5 version and struck with some dependency problems as mention below. I am not sure whether the Teradata Eclipse Plugin works for MYEclipse.
Can anybody assist me in resolving these?

annot complete the install because some dependencies are not satisfiable
Unsatisfied dependency: [com.teradata.datatools.dtpsupportFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.datatools.sqltools.sql.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.datatools.sqltools.result.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.datatools.sqltools.editor.core.ui/1.0.0
Unsatisfied dependency: [com.teradata.datatools.xmlservicesFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.datatools.sqltools.routineeditor.ui/1.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.plan 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.editor.core.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.editor.core.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.ui 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.editor.core.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.xsltmanager.wizards 13.0.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.plan 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.xsd 13.0.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.javabean 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.sql.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.sqldev.dialogs 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.result.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.plan 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.editor.core.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.editor.core.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.plan 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.sql.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.sqldev.dialogs 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.result.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.copycompare 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.sqldev.dialogs/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.xsd 13.0.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.dtp.sqltools/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.xsd 13.0.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtp.sqltools.plan/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtpsupportFeature.feature.group/0.0.0
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtp.compareview/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtp.sqltools.ui/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.datatools.sqltools.result.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtp.sqltools.plan.preferences/[13.0.0.200910281454,13.0.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.sqldev.dialogs/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtp.copycompare/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.datatools.sqltools.editor.core.ui/1.0.0
Unsatisfied dependency: [com.teradata.datatools.enhancementsFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtp.find/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.pluginFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.javadevelopmentFeature.feature.group/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.pluginFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.xmlservicesFeature.feature.group/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.pluginFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtpsupportFeature.feature.group/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.pluginFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.enhancementsFeature.feature.group/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.poweredbypulse.profile-480869-rmb-355559 2.0.0.0000000020] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.pluginFeature.feature.group/0.0.0
Unsatisfied dependency: [com.poweredbypulse.profile-480869-rmb-355559 2.0.0.0000000020] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.javadevelopmentFeature.feature.group/0.0.0
Unsatisfied dependency: [com.poweredbypulse.profile-480869-rmb-355559 2.0.0.0000000020] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.enhancementsFeature.feature.group/0.0.0
Unsatisfied dependency: [com.poweredbypulse.profile-480869-rmb-355559 2.0.0.0000000020] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtpsupportFeature.feature.group/0.0.0
Unsatisfied dependency: [com.poweredbypulse.profile-480869-rmb-355559 2.0.0.0000000020] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.xmlservicesFeature.feature.group/0.0.0
Unsatisfied dependency: [com.teradata.datatools.xmlservicesFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtp.xsd/[13.0.0.200910281454,13.0.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.xmlservicesFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.xsltmanager.wizards/[13.0.0.200910281454,13.0.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.xmlservicesFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtpsupportFeature.feature.group/0.0.0
Unsatisfied dependency: [com.teradata.datatools.xmlservicesFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.datatools.sqltools.routineeditor.ui/1.0.0
Unsatisfied dependency: [com.teradata.datatools.xmlservicesFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.enhancementsFeature.feature.group/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.result 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.dtp.sqltools/0.0.0
Unsatisfied dependency: [com.teradata.datatools.jxsp 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.sqldev.dialogs/0.0.0
Unsatisfied dependency: [com.teradata.datatools.jxsp 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.dtp.sqltools/0.0.0
Unsatisfied dependency: [com.teradata.datatools.sqldev.dialogs 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.result.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.sqldev.dialogs 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.dtp.sqltools/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.find 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.dtp.copycompare/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.find 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.sqldev.dialogs/0.0.0
Unsatisfied dependency: [com.teradata.datatools.xsltmanager.wizards 13.0.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.xsltmanager.wizards 13.0.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.dtp.sqltools/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.plan 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.editor.core.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.plan 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.plan 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.dtp.sqltools/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtpsupportFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtp.sqltools.result/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.dtpsupportFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.datatools.sqltools.editor.core.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtpsupportFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.datatools.sqltools.sql.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtpsupportFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtpsupportFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtp.sqltools/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.editor.core.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.sql.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.compareview 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.sqldev.dialogs/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.compareview 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.dtp.copycompare/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.ui 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.dtp.sqltools.plan/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.ui 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.editor.core.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.javabean 13.1.0.200910281454] requiredCapability: osgi.bundle/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.javabean 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.dtp.sqltools/0.0.0
Unsatisfied dependency: [com.teradata.datatools.javabean 13.1.0.200910281454] requiredCapability: java.package/com.teradata.datatools.jxsp.wizards/0.0.0
Unsatisfied dependency: [com.teradata.datatools.javabean 13.1.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.sqldev.dialogs/0.0.0
Unsatisfied dependency: [com.teradata.datatools.javadevelopmentFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.dtpsupportFeature.feature.group/0.0.0
Unsatisfied dependency: [com.teradata.datatools.javadevelopmentFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.javabean/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.javadevelopmentFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.enhancementsFeature.feature.group/0.0.0
Unsatisfied dependency: [com.teradata.datatools.javadevelopmentFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.jxsp/[13.1.0.200910281454,13.1.0.200910281454]
Unsatisfied dependency: [com.teradata.datatools.javadevelopmentFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/com.teradata.datatools.xmlservicesFeature.feature.group/0.0.0
Unsatisfied dependency: [com.teradata.datatools.javadevelopmentFeature.feature.group 13.1.0.200910281454] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.datatools.sqltools.routineeditor.ui/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.plan.preferences 13.0.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.dtp.sqltools.plan/0.0.0
Unsatisfied dependency: [com.teradata.datatools.dtp.sqltools.plan.preferences 13.0.0.200910281454] requiredCapability: osgi.bundle/com.teradata.datatools.sqldev.dialogs/0.0.0

Thanks.
Swami

1 REPLY
Teradata Employee

Re: How to install Teradata Eclipse plugin on MyEclipse7.5?

The Teradata Eclipse plug-in, as well as Eclipse DTP plug-ins are dependent on other Eclipse plug-ins, often referring to the plug-in by version number. It appears that MyEclipse 7.5 contains the Eclipse Data Tools plug-ins but some of them have been rebuilt by MyEclipse, changing the version numbers. This is causing the dependency failures at installation. Even trying to update Ganymede Data Tools into MyEclipse 7.5 failed as Eclipse DTP dependencies were unsatisfied. I don't have a workaround for this problem.