Multiload + LDAP

Tools & Utilities
Enthusiast

Multiload + LDAP

All,

I am running muliload job. We have LDAP concept here. Our ID's are in sync with LDAP authentication.

When i am running my mulltiload job I am getting below error:(Also PFA attachment)

UTY1006 CLI error : 244, MTDP : EM_SSOLOGONFAIL(224): SSO logon failed by gateway.

Please help!!!

Thanks,

Tushar

4 REPLIES
Teradata Employee

Re: Multiload + LDAP

Hi Tushar,

The screen shot only has the MLOAD error and from this screen shot alone we don’t know what is going on. The LDAP mechanism all happens on the server side and minimally we need the /var/log/messages from all the nodes (if it is a multi-node system) that covers the time of this LDAP logon failure. I assume that LDAP has been properly configured on the database system and so alternatively you can try with “tdsbind” to see if the LDAP configuration was setup properly.

Thanks!

--Ivy.

Enthusiast

Re: Multiload + LDAP

My Script:

.logmech ldap

.logtable dbname.students1;

.logon tdpid/id,pwd;

From here only script getting failed.

UTY1006 CLI error : 244, MTDP : EM_SSOLOGONFAIL(224): SSO logon failed by gateway.

Teradata Employee

Re: Multiload + LDAP

Has your Teradata system been configured to support LDAP authentication? Does LDAP work for other tools / applications?

If so, check DBC.Software_Event_LogV for more detailed information regarding the failure.

Teradata Employee

Re: Multiload + LDAP

Yes, this error mean that there is an LDAP authentication failure. Since, you are using the LDAP mechanism, we assume that you have configured LDAP on the database server to which you are attempting to connect to. If this assumption is correct, then please ssh to the database node and then look at /var/log/messages file to see what is complaining about w.r.t. the LDAP failure (you can search this /var/log/messages file for ldap). If you get the error message that is logged in /var/log/messages on the database node, then we may be able to better help you diagnose this problem. What version of database are you running?