[TPT 16.00] tbuild -z 600 -h 24M encounters memory warning

Tools & Utilities
Enthusiast

[TPT 16.00] tbuild -z 600 -h 24M encounters memory warning

tbuild -z 600 -h 24M -f /export/etl/tmp/STG_FeedActionEvent_Test-TPT-1234232.02.tpt -v /export/etl/tmp/STG_FeedActionEvent_Test-TPT-1234232.02.jobvars -u "TargetTdpId='dwdev.corp.linkedin.com',TargetUserName='ETL_P2A',TargetWorkingDatabase='DWH_STG',TargetTable='STG_FeedActionEvent_Test',SourceDirectoryPath='/mnt/n001/data/temp/feed_action_event_test',SourceFileName='*.gz',SourceTextDelimiter='TAB'" -j STG_FeedActionEvent_Test-1234232.02
Teradata Parallel Transporter Version 16.00.00.02
TPT_INFRA: TPT02375: Warning: The -h memory size exceeds the maximum allowed value and will be lowered to 0.
Job log: /opt/teradata/client/16.00/tbuild/logs/STG_FeedActionEvent_Test-1234232.02-218.out

I don't encounter this warning while using 15.10 or 14.10. I can't find any document about this. What is wrong with 24M shared memory?

Accepted Solutions
Teradata Employee

Re: [TPT 16.00] tbuild -z 600 -h 24M encounters memory warning

Beginning in 16.00.00, TPT now determines the amount of shared memory to allocate, and does so dynamically.

This should alleviate the need for the -h command line option.

 

There was a bug in the code that issued that warning; in reality the amount of shared memory is reset to a high enough value

(probably 4GB) to run the job; not 0. And the job then continued to run.

 

The bug was fixed in 16.10.00.002.

 

In the meantime, you should be able to remove the -h 24M from the command line and run your job and we will take care of the

shared memory for you.

 

-- SteveF
1 ACCEPTED SOLUTION
5 REPLIES
Teradata Employee

Re: [TPT 16.00] tbuild -z 600 -h 24M encounters memory warning

Beginning in 16.00.00, TPT now determines the amount of shared memory to allocate, and does so dynamically.

This should alleviate the need for the -h command line option.

 

There was a bug in the code that issued that warning; in reality the amount of shared memory is reset to a high enough value

(probably 4GB) to run the job; not 0. And the job then continued to run.

 

The bug was fixed in 16.10.00.002.

 

In the meantime, you should be able to remove the -h 24M from the command line and run your job and we will take care of the

shared memory for you.

 

-- SteveF
Enthusiast

Re: [TPT 16.00] tbuild -z 600 -h 24M encounters memory warning

Got it.

 

I will need to keep -h 24M for 15.10 tbuild, but avoid -h for 16.00+

Teradata Employee

Re: [TPT 16.00] tbuild -z 600 -h 24M encounters memory warning

Correct. Or leave the -h 24M there and just ignore the warning.

 

-- SteveF
Enthusiast

Re: [TPT 16.00] tbuild -z 600 -h 24M encounters memory warning

Normally the wrapper script will detect exit code, in this case, I will have to ignore exit code = 4 for all types of warnings.

Teradata Employee

Re: [TPT 16.00] tbuild -z 600 -h 24M encounters memory warning

warnings should never be considered an error condition.

-- SteveF