TTU 14.00 Windows silent install and uninstall

Tools & Utilities
Enthusiast

TTU 14.00 Windows silent install and uninstall

I'm trying to automate the installation (and deinstallation for patching, and upgrades) of TTU on Windows. I have tried the below wtih the results seen:

Installation

A) Straight silent install from documentation:

setup.exe /s /f1"./setup.iss

Result: does not do work, nothing is installed

B) Record installation and then playback:

setup.exe /r /f1"C:\Temp\ttu_install.iss"

setup.exe /s /f1"C:\Temp\ttu_install.iss /f2"C:\temp\ttu_install.log"

 

Result: Nothing is installed, log contents below:

[InstallShield Silent]

Version=v5.00.000

File=Log File

[ResponseResult]

ResultCode=-12

 

Deinstallation

A) Using documented script:

cscript uninstall_TTU.vbs  TSAW TMGR TDWM TDADMIN TWA TQSCLIENT TQSSERVER TQSADMIN TSWIZ TIWIZ VECOMP TSET SQLA JMSAXSMOD OLEDBAXSMOD MQAXSMOD NPAXSMOD SQLPP TDOLEDB TPUMP PMON FASTEXP MLOAD FASTLD BTEQ PIOM TDODBC CLIv2 TDICU TERAGSS /FORCE:TRUE

 

Result: After a really long time, none of the software is deinstalled

 

B) Using documented script for single software:

cscript uninstall_TTU.vbs  TMGR

 

Result: Again, the software is not deinstalled

 

 

So my questions is how do others get this process automated? Should I be writing some sort of script which can do this myself (already looking into this possibility)? If it helps, we use Altiris as our software management tool using which the installation/deinstallation would be handled.

 

Any help is appreciated.

 

Thanks.

2 REPLIES
Teradata Employee

Re: TTU 14.00 Windows silent install and uninstall

1) Is "Windows Installer" services running on the system? It should run when you involke silent installations/uninstallations.

2) Try following command for silent installtion for individual products: If you are trying for TTU suite then it may not work.

"Setup.exe /S /v "/qn"

Note that 'S' is capital

Highlighted
Enthusiast

Re: TTU 14.00 Windows silent install and uninstall

Thanks for replying Sudhansu.

I tried using 14.00.02 and the silent installation went through. It runs in the background regardless of the switch used and takes a while to spool up so it was not obvious (actually crashed my machine with multiple concurrent silent install attempts the first time), but it does work.

I got the uninstall to work as well. By default the PRIORTOVERSION is set to 14.00.00.00 so it must be set appropriately to uninstall higher prior versions. Again this was a bit of work since TTU actually consists of multiple versions so even using 14.00.04 was not working (I ended up using 14.10.00 which works fine). 

Hope this helps others.