Tables Node disappears in SQL Assistant When I click on It

Tools & Utilities
Enthusiast

Tables Node disappears in SQL Assistant When I click on It

I fired up SQL Asisstant for the first time and tried viewing the available tables. When I click on tables to expand them in the db exlorer, the Tables link disappers completely. Could i be a permission issue or should I see a specific message when there's a permission issue? I don't think there's anything wrong with my connection because the databes are showing up.

5 REPLIES
Junior Contributor

Re: Tables Node disappears in SQL Assistant When I click on It

There are two possible reasons:

 

#1:

There are no tables in that database, when you click on Views/Tables/Macros/Procedures/Functions and there's no rew returned, the node is removed.

 

#2 I found out last week, it's either a bug or an Enhancement Request :-)

You connect using an ANSI mode session and then all object names are case sensitive.

Remove the database from the tree, check dbc.DatabasesV for the correct upper/lowercase and add it back using the correct name. 

Enthusiast

Re: Tables Node disappears in SQL Assistant When I click on It

Hi 

 

Thanks for your reply. The tables do exist and The case issue isn't a problem here. Even more confusing is that I can open the db in TD Admnistraor and view everyhtign fine so I don't think it has anythign to do with permissions either. I'm stumped. 

Junior Contributor

Re: Tables Node disappears in SQL Assistant When I click on It

Did you double check the session mode?

SELECT Transaction_Mode 
FROM dbc.SessionInfoV
WHERE SessionNo = SESSION

A=ANSI

T=Teradata

Enthusiast

Re: Tables Node disappears in SQL Assistant When I click on It

Hi,

 

I ran that query and it returns T.

Junior Contributor

Re: Tables Node disappears in SQL Assistant When I click on It

Try installing the latest patch level of SQL Assistant, if the problem persists, open an incident with Teradata support