Teradata Parallel Transporter Issue

Tools & Utilities
Enthusiast

Teradata Parallel Transporter Issue

Hi Forum,

My Teradata box is multi-tenant meaning , one customer isn’t supposed to see another customer’s tables/data. So we have XVIEWS enabled for the users. Now, the issue is,a user from one of the customer team is trying to run a TPT and is getting the below error.

C:\Test\Marsh>tdload -j job_variables.txt

Teradata Load Utility Version 13.10.00.02

Got RDBMS Error 5315: The user does not have SELECT access to DBC.Indices.IndexType

I should not , at any cost, provide the user access to DBC.Indices as it would reveal the existence of other customers, if the user later tries to access /read that table, at a later point. I do have given access to the DBC.IndicesX and DBC.IndicesVX to the user.

Any thoughts on why the user is still getting the error “The user does not have SELECT access to DBC.Indices.IndexType”

Is it a must for the user to have access to DBC.Indices for using Teradata Parallel Transporter? Any work around for enabling XViews for TPT?

Any suggestions /insight would help me a lot

Thanks

Roopalini

5 REPLIES
Teradata Employee

Re: Teradata Parallel Transporter Issue

If you do not allow access to the Indexes table, then you cannot use the "tdload" feature of TPT.

You must create a script and use "tbuild".

When you try to use tdload, the Easy Loader feature of TPT needs to look up the indexes of the target table so that we can determine which protocol is the best protocol to use.

There is no workaround.

-- SteveF
Enthusiast

Re: Teradata Parallel Transporter Issue

Hi Steve,

I actually got a workaround from Teradata. I believe they modified the tableqry.dll of TPT to look to DBC.INICESVX instead of DBC.INDICESV which the user didn't have access to, and resolved the issue.

Thanks

Roopalini

Enthusiast

Re: Teradata Parallel Transporter Issue

Hi Steve,

I have  another question. Do we have  a 64 bit version of Teradata parallel Transporter? The one I have installed requires a 32 bit JRE and so I am having issues making the other Teradata clients work , which requires a 64 bit JRE like after I make the TPT work , my Teradata studio doesn't work as it requires a 64 bit JRE. Could you please help me here?

Teradata Employee

Re: Teradata Parallel Transporter Issue

TPT is a 32-bit application.

There is no 64-bit version of TPT. Unless you are using the Wizard, there is no need for any JRE. Thus, just do not use the Wizard (I would rather it not be used anyway, but that is my opinion).

-- SteveF
Enthusiast

Re: Teradata Parallel Transporter Issue

Thanks for clarifying Steve!!