Teradata SQL Assistant is weird slow

Tools & Utilities

Teradata SQL Assistant is weird slow


I'm upgrading SQL Assistant from 13.01 to 13.11 recently and noticed that SQL Assistant will, at some point of usage, become slower and slower. It eat up ~50% of CPU and the GUI stop to respond for a few minutes upon each operation. The plugin for Eclipse exhibit the same GUI freeze problem.

Any clue what the problem is? I'm using Win XP 32bit OS to run SQL Assistant.

Tags (1)
Teradata Employee

Re: Teradata SQL Assistant is weird slow

We haven't seen things get sluggish over time.

How much time are you talking about before it becomes sluggish? Does it seem to be just time that causes the problems? When the CPU is being used heavily are there symptoms are there indications in the application that it's waiting for something (like a rotating arrow in the Data Source Explorer tree when a node is expanded for the first time)?

Is the database system you're connected to heavily used? Or have a very large number of databases and users in it?

Do you run queries that return a very large number of rows that you have the application display?

I guess in order to try to figure this out we're going to need more information about what was happening before the problem occurs. And if the problem comes up gradually, maybe a description of how you're using the tool before the problem occurs could help.

Re: Teradata SQL Assistant is weird slow

It was okay after the first time installation. After I run several simple scripts (some CREATE FUNCTION statements and SQL Query provided in "SQL External Routine Programming" Appendix A), it became sluggish suddenly. I didn't found any clear evidence that cause the problem. What I was doing was just compiling my UDF, register them in Teradata and run sample query. I've tried to uninstall 13.11, re-install 13.01 and then upgrade to 13.11, which seems doesn't make any difference.

Actually when it becomes sluggish, I close it and restart, everything is slow (even before I connect the database). The plugin for Eclipse is the same, when I quit and restart Eclipse, a single mouse click in the editor takes 1/2 minute to respond.

The database is 13.01 simulator which is only used by myself at the moment.

One of the brilliant features of 13.11 that attracts me to upgrade is "Teradata SQL History", where I can see the detailed compile error during CREATE/REPLACE FUNCTION. In 13.01, compile results is only visible when no error was reported. Could it be a problem that the compilation of the UDF corrupted the application?

Re: Teradata SQL Assistant is weird slow

open ODBC 32 or 64 console - click on tab called TRACING, click stop traching. this would solve the problem.

I happened with me and it's now resolved.