We recently installed TTU 16.20 and unable to connect to oracle

Tools & Utilities
Teradata Employee

We recently installed TTU 16.20 and unable to connect to oracle

Teradata Parallel Transporter Version 16.20.00.01 64-Bit
Job log: /opt/teradata/client/16.20/tbuild/logs/tdadmin-106.out

 


Teradata Parallel Transporter Load Operator Version 16.20.00.01
LOAD_OPERATOR: private log not specified
Teradata Parallel Transporter ODBC Operator Version 16.20.00.01
ODBC_OPERATOR: private log not specified
ODBC_OPERATOR: connecting sessions
ODBC_OPERATOR: TPT17122: Error: unable to connect to data source
ODBC_OPERATOR: TPT17101: Fatal error received from ODBC driver:
              STATE=82, CODE=0,
              MSG='523 80'
LOAD_OPERATOR: connecting sessions
LOAD_OPERATOR: preparing target table
LOAD_OPERATOR: entering Acquisition Phase
LOAD_OPERATOR: disconnecting sessions
ODBC_OPERATOR: Total processor time used = '0.005 Second(s)'
ODBC_OPERATOR: Start : Fri Jun  8 10:28:33 2018
ODBC_OPERATOR: End   : Fri Jun  8 10:28:36 2018
LOAD_OPERATOR: Performance metrics:
LOAD_OPERATOR:     MB/sec in Acquisition phase: 0
LOAD_OPERATOR:     Elapsed time from start to Acquisition phase:   3 second(s)
LOAD_OPERATOR:     Elapsed time in Acquisition phase:   0 second
LOAD_OPERATOR:     Elapsed time in Application phase:   0 second
LOAD_OPERATOR:     Elapsed time from Application phase to end: < 1 second
LOAD_OPERATOR: Total processor time used = '0.047993 Second(s)'
LOAD_OPERATOR: Start : Fri Jun  8 10:28:33 2018
LOAD_OPERATOR: End   : Fri Jun  8 10:28:36 2018
Job step INSERT_TD_TABLE terminated (status 12)
Job tdadmin terminated (status 12)
Job start: Fri Jun  8 10:28:33 2018
Job end:   Fri Jun  8 10:28:36 2018

5 REPLIES
Teradata Employee

Re: We recently installed TTU 16.20 and unable to connect to oracle

This error generally means that you are pointing to 32-bit drivers but need the 64-bit version (or maybe vice versa).

Check the PATH / LD_LIBRARY_PATH / etc.

Teradata Employee

Re: We recently installed TTU 16.20 and unable to connect to oracle

Does 16.20 only support 64 bit datadirect drivers when connecting to Oracle?
Teradata Employee

Re: We recently installed TTU 16.20 and unable to connect to oracle

Does 16.20 only support 64 bit datadirect drivers when connecting to Oracle?
Teradata Employee

Re: We recently installed TTU 16.20 and unable to connect to oracle

Pointed to 32-bit but still receiving a different error

ODBC_OPERATOR: TPT17204: Driver Manager load error: 'lib_Ticu27.so: wrong ELF class: ELFCLASS32'

Teradata Employee

Re: We recently installed TTU 16.20 and unable to connect to oracle

It seems you are invoking 64-bit tbuild, so you do need the 64-bit drivers.

Double check the odbc.ini file (by default the one in <TPT16.20 install directory>/odbc) to be sure the Driver= points to the correct driver file, as well as having the correct library search path.

 

TPT 16.20 supports Simba or Oracle drivers for connecting to Oracle, in addition to the bundled / branded Data Direct drivers & driver manager.