not be able to install TTU 15 on RHEL - getting rpm errors

Tools & Utilities
Enthusiast

not be able to install TTU 15 on RHEL - getting rpm errors

Hi fellows, 

I need your help.

 

So. We want to install TTU version 15.0 on our server Red Hat Enterprise Linux Server release 6.7 (Santiago).

Well, When we were installing we're getting some errors related to rpms and not all tools were installed. 

When I want to execute any utilitites on the server it shows me: 

 

[root@MISERVER bin]# bteq
-bash: bteq: command not found
[root@MISERVER bin]# tpump
/opt/teradata/client/15.00/bin/tpumpexe: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
[root@MISERVER bin]# fastload
fastload: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
[root@MISERVER bin]#

so. I tried to download and install that library  libstdc++.so.6 through yum install but I can't: 

ejecuta yum update libstdc++*
I tried to user --skipe broken, but I'm not be able to install any rpm and shows me: 

You could try using --skip-broken to work around the problem
** Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:
mqaxsmod1500-15.00.00.00-1.noarch has missing requires of libmqic.so
mqaxsmod1500-15.00.00.00-1.noarch has missing requires of libmqmcs.so
mqaxsmod1500-15.00.00.00-1.noarch has missing requires of libmqm.so
mqaxsmod1500-15.00.00.00-1.noarch has missing requires of libmqm.so()(64bit)

I have checked this with RH support and told me: 

 

The error you are receiving shows a third party package and library:

 

 mqaxsmod1500-15.00.00.00-1.noarch has missing requires of libmqic.so

 

In this case, the error is probably due to third party repository. Please, check with the vendor or disable it and try update the package again.

 

Please, your kindly help. We are on this issue almost 2 weeks. :S

thank you.

2 REPLIES
Enthusiast

Re: not be able to install TTU 15 on RHEL - getting rpm errors

anyone can help me guys?Man Frustrated

 

Highlighted
Teradata Employee

Re: not be able to install TTU 15 on RHEL - getting rpm errors

Check the TTU for RHEL Installation Guide B035-3121 (available from www.info.teradata.com).

 

You need to use "yum install" to add missing libraries, not "yum update".

You may find that you need libc.so.6 and libgcc_s.so.6 in addition to libstdc++.so.6