ARC/named pipe question: archive/copy a database hierarchy

Tools
Enthusiast

ARC/named pipe question: archive/copy a database hierarchy

Hi,

With arcmain  I am trying to archive/copy multiple databases, i.e. a hierarchy:

DEVELOPMENT

  \--  DATAMART_1

 \-- DATAMART_2

(structure is in place on both machines)

I am using named pipe for exchange. I.e. in one terminal I give the "arcmain - logon to source - archive" command, in another i do an "arcmain - logon to target - copy" command.

If I copy DATAMART_1 ==only== (so, no hierarchy), it works. The archive process kicks off as soon as the copy command is given, and the tables are copied across fine.

However if I go one level higher, giving the command to copy 'DEVELOPMENT', the archiving starts as soon as the copy process is initiated but the copying never starts logging any data. After the process is completed, the COPY process gives a 'Completed' message, however the ARCHIVE reports a broken pipe (i.e., copy process stopped unexpectedly).

This is output from the terminal where the COPY command is executed:

06/27/2012 20:35:52  copy data tables (DEVELOPMENT),abort, release lock, file=ARCNPIPE;
06/27/2012 20:35:53 UTILITY EVENT NUMBER - 37
06/27/2012 20:35:54 --- ARCHIVED AT 06-27-12 20:35:53
06/27/2012 20:35:54 --- ARCHIVED FROM ALL AMP DOMAINS
06/27/2012 20:35:54 --- UTILITY EVENT NUMBER IN ARCHIVE - 1151227
06/27/2012 20:35:54 --- SOURCE RDBMS VERSION: LANGUAGE SUPPORT MODE:Standard;
--- RELEASE:13.00.01.12; VERSION:13.00.01.12;

.... and then nothing anymore.

the other terminal is just working fine as if a reader is there.

Any suggestions on what to do?

thank you

1 REPLY
Enthusiast

Re: ARC/named pipe question: archive/copy a database hierarchy

Actually now that I am testing again, the process did complete succesfully (no broken pipe, DUMP completed) but there were no tables written or anything:

output from terminal on 'copy' side:

06/27/2012 22:02:45 ---  Begin dictionary phase

06/27/2012 22:02:46  STARTING TO COPY DATABASE "....."

06/27/2012 22:02:46  NEED TO RE-HASH ROWS

06/27/2012 22:02:46  DICTIONARY COPY COMPLETED

06/27/2012 22:02:46 ---  End dictionary phase

06/27/2012 22:02:46 ---  Begin data phase

06/27/2012 22:02:46 ---  End data phase

06/27/2012 22:02:46  "....." - LOCK RELEASED

06/27/2012 22:02:46

06/27/2012 22:02:46  STATEMENT COMPLETED

06/27/2012 22:02:46

all in one second!

Any ideas what is wrong?

Any help would be much appreciated!