FastLoad AXSMOD invoke error

Tools
Teradata Employee

FastLoad AXSMOD invoke error

Hi,

       Fastload with Access Module have a error:

**** 07:08:44 Teradata Database Release: 13.10.00.10

**** 07:08:44 Teradata Database Version: 13.10.00.14

**** 07:08:44 Current CLI or RDBMS allows maximum row size: 64K

**** 07:08:44 Character set for this job: ASCII

0002 database petl;

**** 07:08:44 Command completed successfully

0003 BEGIN LOADING     book1   ERRORFILES  book1_E1, book1_e2 INDICATORS;

**** 07:08:44 Indicator mode is set to ON

**** 07:08:45 Number of FastLoad sessions connected = 2

**** 07:08:45 FDL4808 LOGON successful

**** 07:08:48 Number of AMPs available: 2

**** 07:08:48 BEGIN LOADING COMPLETE

0004 AXSMOD ./amEXTPGM.so "CSV2FLD 4 ";

**** 07:08:48 I/O Error on Open: 3, Text: Requested Access Module not

              found

**** 07:08:48 Error: Invalid pmHandle parameter

**** 07:08:48 Error: Invalid pmHandle parameter

     ===================================================================

     =                                                                 =

     =          Logoff/Disconnect                                      =

     =                                                                 =

     ===================================================================

**** 07:08:48 Logging off all sessions

**** 07:08:48 Total processor time used = '0.17 Seconds'

     .        Start : Fri Aug 23 07:08:28 2013

     .        End   : Fri Aug 23 07:08:48 2013

     .        Highest return code encountered = '12'.

**** 07:08:48 FastLoad Paused

     the amExtPgm.c is ok on the other site.  I compile it with this command:gcc -shared -fPIC amExtPgm.c -o amEXTPGM.so

      CSV2FLD is a program to pre-process csv file. it runs ok independently.

       Does anyone know what reason for the error:Requested Access Module not found? If it's not right for compile command?         

       thank for you help!

1 REPLY
Teradata Employee

Re: FastLoad AXSMOD invoke error

Try following things:

1) add the axsmod location in path variable and do not include "./" in script.

2) piom is responsible to communicate between fastload and axsmod. Check if you have correct version of piom installed.

3) Check the permission of the axsmod file for the user with which fastload program is executed.