Fastload via MS-DOS batch file

Tools
Teradata Employee

Fastload via MS-DOS batch file

Hi,

I have created a batch file as-
C:\Program Files\NCR\Teradata Client\Bin\bteq < C:\Documents and Settings\Indrajit Gaikwad\My Documents\School_Project\DDL\School_Master.txt > C:\Documents and Settings\Indrajit Gaikwad\My Documents\School_Project\Logs\SM_DDL.log
C:\Program Files\NCR\Teradata Client\Bin\fastload < C:\Documents and Settings\Indrajit Gaikwad\My Documents\School_Project\FLOAD\School_Master.txt > C:\Documents and Settings\Indrajit Gaikwad\My Documents\School_Project\Logs\SM_FLOAD.log

But this batch does not run. Niether the log files are created.

Can you advise.
3 REPLIES

Re: Fastload via MS-DOS batch file

my guess is that It may be because of the spaces in your command, so you might have to put things in double quotes. ie

"C:\Program Files\NCR\Teradata Client\Bin\bteq" < "C:\Documents and Settings\Indrajit Gaikwad\My Documents\School_Project\DDL\School_Master.txt" > "C:\Documents and Settings\Indrajit Gaikwad\My Documents\School_Project\Logs\SM_DDL.log"

and so forth...
N/A

Re: Fastload via MS-DOS batch file

Add the teradata utilities' directory path in the PATH variable of the DOS and then run these utilities by simply typing c:\> bteq < directory\urfile > directory\logfile. and it will be more helpful if u browse urslef in the directory where u have scripts and then run
c:\ur_directory> bteq < file > log
N/A

Re: Fastload via MS-DOS batch file

try the path as
c:\docume~1\ ..

like that