RDBMS error 8018 while running fastload.

Tools
Enthusiast

RDBMS error 8018 while running fastload.

All,
I get this error while running the fastload.
the table is locked and i had to drop and recreate the table, and I still get this error.

**** 10:34:38 Number of recs/msg: 103
**** 10:34:38 Starting to send to RDBMS with record 1
**** 10:38:58 RDBMS error 8018: The session id is illegal.
===================================================================
= =
= Logoff/Disconnect =
= =
===================================================================

**** 10:38:58 Logging off all sessions
**** 10:38:59 Total processor time used = '3.32813 Seconds'
. Start : Fri Jul 14 10:34:29 2006
. End : Fri Jul 14 10:38:59 2006
. Highest return code encountered = '12'.
**** 10:38:59 FastLoad Paused

The documentation says:
8018 The session id is illegal.
Explanation: The session id specified in any request is
not valid. Either the session has never been logged on or
the session id is simply malformed.
Generated By: GtwASTsk, GtwCnTsk, GtwIOTsk.
For Whom: End user.
Remedy: Correct the session number and resubmit
the request.

But how do we correct the session num?

thanks
3 REPLIES
Enthusiast

Re: RDBMS error 8018 while running fastload.

solved this issue bu reducing the number of seesions assigned in the multiload and fastload scripts.

in multiload and fastload scripts
sessions 1;

it worked fine with no errors, our environment has 3 nodes and i set my statement to
sessions 3;
and this worked fine with tno errors.

Teradata Employee

Re: RDBMS error 8018 while running fastload.

If you consistently have trouble running with more than one session per node, you probably have a network issue. For example, you may see this behavior if one adapter is set to half duplex but the other adapter / switch / router is set to full duplex.

"Auto" negotiation of link speed / duplex is great when it works, but when it doesn't the result can be confusing errors that are hard to track down.

Consider "hard coding" these settings rather than using "Auto".
Enthusiast

Re: RDBMS error 8018 while running fastload.

Fred,
sorry for coming back to this after a long time.
where do we set these "settings"

should we set it to full duplex or half duplex?

appreciate your help.