SQL Assistant 13 Explorer View doesn't show all tables

Tools

SQL Assistant 13 Explorer View doesn't show all tables

Teradata experts,

I use Teradata Assistant to view our SQL Server. I recently upgraded to v. 13, and I can no longer see all my tables in Explorer view, though I can still query them. It looks like Explorer View is only allowing a set number of tables (around 40).

I tried choosing "Use alternate scheme to load the Explorer Tree for 'Unknown' vendors" in the Options dialog, but it didn't help. I've also tried refreshing the database multiple times. Plus I've looked for a setting somewhere that limits the number of tables displayed in the Explorer tree, but I haven't found anything.

This is somewhat problematic because I can't easily see the columns for the tables that aren't showing up. Any suggestions?

Thanks!

Kathryn
Tags (1)
3 REPLIES
Teradata Employee

Re: SQL Assistant 13 Explorer View doesn't show all tables

The "Use alternate schema..." option applies only to 'unknown' databases. That is vendors whose databases we do not provide any specific support for. We have specific support for SQL Server.

There is no internal limit for the number of tables displayed in the tree. (I have seen over 500 at times)

When it fails to display all the tables does it display any error message, or maybe write an error to \Documents and settings\\Application Data\Teradata\SQL Assistant\SQLAError.txt

I dont remember if SQL Server allows this, but do you maybe have 2 tables whose names are identical except for the case of the characters?
We ran into that problem with Oracle - it is fixed in the 13.0.0.9 efix.

Enthusiast

Re: SQL Assistant 13 Explorer View doesn't show all tables

Hi Mike,

Could you please advice on the below messages

SQLA Version: 13.10.0.4

System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

   at System.Net.UnsafeNclNativeMethods.OSSOCK.recv(IntPtr socketHandle, Byte* pinnedBuffer, Int32 len, SocketFlags socketFlags)

   at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags, SocketError& errorCode)

   at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)

   at Teradata.Client.Provider.WpTcpTransport.ReadLanHeader(Buffer buffer, Int32 timeout, Int32 readBytes)

   at Teradata.Client.Provider.WpTcpTransport.Receive(Buffer buffer, Int32 timeout)

   at Teradata.Client.Provider.WpSession.Receive(Buffer buffer, Int32 timeout)

   at Teradata.Client.Provider.WpMessageManager.Receive(Int32 timeout)

   at Teradata.Client.Provider.WpStartRequestManager.Action()

   at Teradata.Client.Provider.Request.ExecuteStartRequest(String commandText, TeraTypeBase[][] parameters, ExecutionMode executionMode, Boolean asynchronous, Boolean isTrustedRequest)

   at Teradata.Client.Provider.WpSession.RetrieveSessionInfo(Request request, Boolean ansiSession)

   at Teradata.Client.Provider.WpSession.FinalizeSessionContext(String version, Boolean ansiSession, PclConfigResponse configResponse)

   at Teradata.Client.Provider.WpSession.Open(Int32 connectionTimeout, String password)

   at Teradata.Client.Provider.Connection.Open(UtlConnectionString connectionString, UInt32 timeout)

   at Teradata.Client.Provider.ConnectionFactory.GetConnection(Object owningObject, UtlConnectionString connStr)

   at Teradata.Client.Provider.TdConnection.Open()

   at Teradata.SQLA.TdConnectInfo.Connect() in F:\ttu1310_efix_snap\tdcli\qman\sqla\TdConnectInfo.vb:line 44

SQLA Version: 13.10.0.4

Teradata.Client.Provider.TdException: [Socket Transport] [115024] Transport error initializing socket. ---> System.Net.Sockets.SocketException: A blocking operation is currently executing

   at System.Net.Sockets.Socket..ctor(AddressFamily addressFamily, SocketType socketType, ProtocolType protocolType)

   at Teradata.Client.Provider.WpTcpTransport.InitSocket(IPAddress ipAddress)

   --- End of inner exception stack trace ---

   at Teradata.Client.Provider.WpTcpTransport.InitSocket(IPAddress ipAddress)

   at Teradata.Client.Provider.WpTcpTransport.Connect(Int32 timeout)

   at Teradata.Client.Provider.WpSession.Open(Int32 connectionTimeout, String password)

   at Teradata.Client.Provider.Connection.Open(UtlConnectionString connectionString, UInt32 timeout)

   at Teradata.Client.Provider.ConnectionFactory.GetConnection(Object owningObject, UtlConnectionString connStr)

   at Teradata.Client.Provider.TdConnection.Open()

   at Teradata.SQLA.TdConnectInfo.Connect() in F:\ttu1310_efix_snap\tdcli\qman\sqla\TdConnectInfo.vb:line 44

SQLA Version: 13.10.0.4

System.NullReferenceException: Object reference not set to an instance of an object.

   at Infragistics.Win.UltraWinTabControl.UltraTabControlBase.OnManagerSelectedTabItemChanged(Object sender, SelectedTabItemChangedEventArgs e)

   at Infragistics.Win.UltraWinTabs.TabManager.set_SelectedTabItem(ITabItem value)

   at Infragistics.Win.UltraWinTabControl.UltraTabControlBase.SetSelectedTab(UltraTab tab)

   at Infragistics.Win.UltraWinTabControl.UltraTabControlBase.set_SelectedTab(UltraTab value)

   at Infragistics.Win.UltraWinTabControl.UltraTab.set_Selected(Boolean value)

   at Infragistics.Win.UltraWinTabControl.UltraTabsCollection.Add(String key, String text)

   at Infragistics.Win.UltraWinTabControl.UltraTabsCollection.Add()

   at Infragistics.Win.UltraWinTabControl.UltraTabControlBase.UltraTabControlCollection.Add(Control value)

   at Teradata.SQLA.AnswerFrm.AddTab(String title, AnswerType typ, String dsn, String language) in F:\ttu1310_efix_snap\tdcli\qman\sqla\AnswerFrm.vb:line 169

   at Teradata.SQLA.MainFrm.GetNewAnswer(AnswerFrm& form, String formTitle, String tabTitle, AnswerType typ, String dsn, String language) in F:\ttu1310_efix_snap\tdcli\qman\sqla\MainFrm.vb:line 169

   at Teradata.SQLA.RunQry.DisplayResults(DbDataReader rdr, String stmt, Int32& rowCnt) in F:\ttu1310_efix_snap\tdcli\qman\sqla\RunQry.vb:line 452

Re: SQL Assistant 13 Explorer View doesn't show all tables

Hi I am first time user of Teradata (version 14.0).  I can connect to a database (DB2) but when I try to expand the table and viewes on the Database explorer, nothing is showing up.  Could anyone please assist me if you had encounter this type of problem.  Thanks Rolando