TELAPI Initialize error on Linux64 TPT API 13.10 "[CLI2: BUFOVFLOW(308): Parcel data too large for receiving buffer.]"

Tools

TELAPI Initialize error on Linux64 TPT API 13.10 "[CLI2: BUFOVFLOW(308): Parcel data too large for receiving buffer.]"

HI,

-With 32 bit TPTAPI libraries (TelApi 13.10) I could connect and fetch the data from Teradata database (13.0).

-But after changing all the related environment variable I could load the 64 bit libraries but could not connect to Teradata database.

While connecting it throws the error, "[CLI2: BUFOVFLOW(308): Parcel data too large for receiving buffer.]".

-In the manual I could find some related stuff for this issue. "If Fetch Maximum data length is less than the actual data to be returned by CLI, CLI will

return a BUFOVFLOW error. Variable length fetch should not be set to 'Y' when parcel mode is set to 'N'."

I am not sure how to set these options related to "dbcarea.h"

Is there any workaround/solution for this issue?

Thanks and Regards,

Harshad

Tags (3)
9 REPLIES
Teradata Employee

Re: TELAPI Initialize error on Linux64 TPT API 13.10 "[CLI2: BUFOVFLOW(308): Parcel data too large for receiving buffer.]"

If you have switched to 64-bit TPTAPI, are you sure you are using 64-bit CLI?

-- SteveF

Re: TELAPI Initialize error on Linux64 TPT API 13.10 "[CLI2: BUFOVFLOW(308): Parcel data too large for receiving buffer.]"

How can I be sure that CLI is 64 bit?? And if it is not how to make it 64bit?

Thanks,

Harshad.

Teradata Employee

Re: TELAPI Initialize error on Linux64 TPT API 13.10 "[CLI2: BUFOVFLOW(308): Parcel data too large for receiving buffer.]"

When you install CLI you can install both 32-bit and 64-bit.

I believe they reside in different directories.

You would have to check the CLI documentation about how to enable one over the other. I am not familiar with that.

-- SteveF

Re: TELAPI Initialize error on Linux64 TPT API 13.10 "[CLI2: BUFOVFLOW(308): Parcel data too large for receiving buffer.]"

HI,

I verified all the env variables and the "libcliv2.so" is taken from lib64 directory. Somebody please advise for this error. We are stuck at this point for quites some time :(..

Regards,

Harshad.

Teradata Employee

Re: TELAPI Initialize error on Linux64 TPT API 13.10 "[CLI2: BUFOVFLOW(308): Parcel data too large for receiving buffer.]"

We are investigating and I will update here when we have a resolution.

-- SteveF

Re: TELAPI Initialize error on Linux64 TPT API 13.10 "[CLI2: BUFOVFLOW(308): Parcel data too large for receiving buffer.]"

Thanks Steven for the follow up.

Please let me know if there is any update on this.

Regards,

Harshad

Teradata Employee

Re: TELAPI Initialize error on Linux64 TPT API 13.10 "[CLI2: BUFOVFLOW(308): Parcel data too large for receiving buffer.]"

Can you please tell me at which customer site you are working?

At the site with which we were working, the problem was an incompatibility between the TPTAPI infrastructure and the Export operator.

Please make sure you have installed the latest patched of papi and the export operator.

-- SteveF

Re: TELAPI Initialize error on Linux64 TPT API 13.10 "[CLI2: BUFOVFLOW(308): Parcel data too large for receiving buffer.]"

Thanks Steven.

One of my Colleague tried to update the Export operator "pexpda00" and it worked for him.

Cheers and Regards,

Harshad

Re: TELAPI Initialize error on Linux64 TPT API 13.10 "[CLI2: BUFOVFLOW(308): Parcel data too large for receiving buffer.]"

I tried to install TPT 13.10  in Linux 64 bit in linux, could not able to find any

Teradata Parallel Transporter Infrastructure (32-bit) software.Only 32 Bits software availble

(tbldda00-13.10.00.00-1.i386.rpm). However there are EXPORT,LOAD,STEAM,UPDATE 64 Bit software are there. Wonder how to configure  Tbuild 32 bit to eanble 64 bit operators.