TPT15.10. The need for TWB_ROOT ?

Tools

TPT15.10. The need for TWB_ROOT ?

Hello,

We are getting errors when running TPT 15.10 on Solaris 10.  Output is :

Teradata Parallel Transporter Version 15.10.00.04 64-Bit

TPT_INFRA: TPT02002: Error: TWB_ROOT environment variable is not defined.

However, The TPT 14.10 User Guide says:  "Replaced TWB_ROOT with the following variable: TPT_install_directory."

The TTU 15.10 Install Guide for Solaris doesn't mention it, referring instead to the TPT_install_directory.   

I believe we have installed correctly, according to the install guide.    tbuild is in the path and appears to be starting (until the error)

The 15.10 Messages reference suggests that it is still required (TPT02002)

So, is TWB_RROT required as an environment variable or not ?  Is an Incident warranted (doco or TTU)?

Thanks

Tags (1)
3 REPLIES

Re: TPT15.10. The need for TWB_ROOT ?

That should be "TWB_ROOT"  ! :)

Teradata Employee

Re: TPT15.10. The need for TWB_ROOT ?

TWB_ROOT is not needed to be set by the user.

Please provide the following:

1. the command you are using to run TPT

2. the contents of your PATH environment variable.

You say you are running TPT 15.10.00.04, but then you mention the 14.10 User Guide.

(Not that it matters, but usually you should be referencing the same version of the User Guide as the version of TPT you are running.)

When running 15.10, "tbuild" should not be in the PATH.

-- SteveF

Re: TPT15.10. The need for TWB_ROOT ?

Sorry for the confusion.  I referenced 14.10 as I was tracing back to find when TWB_ROOT was dropped.  

The message returned doesn't help if it's not needed.

we were running tbuild,  I'll double check the path variable.