Teradata Mapping Manager 2.0.3, error with LogFile permissions

Tools
Enthusiast

Teradata Mapping Manager 2.0.3, error with LogFile permissions

I've just installed TMM 2.0.3, but I get the error "Cannot create log files under ...  Disk may be full or you may not have proper permissions..."

Neither is true.  I am an Administrator on the PC.  I have tried creating test files in the logfiles directory with no problem.

However, I noticed that after install I have two logfile directories,  one in Teradata Mapping Manager/bin/LogFiles in the install path I selected, and one in My Documents/Teradata Mapping Manager/LogFiles.  By default it appears that TMM creates a folder structure in My Documents.

I attempted to change my folder Read Only properties using the "attrib" command ( see http://support.microsoft.com/kb/326549 ). 

So:

Why are there two LogFiles directories ? 

Can I change where TMM looks for the LogFile directory ?

How is it detecting that I don't have permissions ?   This seems to be giving a false positive.

Thanks

P.S.  I'll try installing on another drive, but I believe it should work OK where it is (in my preferred location!).

Tags (1)
10 REPLIES
Enthusiast

Re: Teradata Mapping Manager 2.0.3, error with LogFile permissions

Sorry guys,

I can't get it to work in any install directory I choose.

Version 2.0.2 works though so I'll stick with that for now.

Enthusiast

Re: Teradata Mapping Manager 2.0.3, error with LogFile permissions

What operating system are you using?

The LogFiles folder under your install path is the "old" log files location, and should only have a readme file in it that tells you where the "new" log files folder is located. The code was supposed to change in 2.0.3 to write all log files to the LogFiles folder under the current user's My Documents folder. I cannot reproduce this problem on my Win 7 machine, but I will ask the programmers to check the code again to make sure that one of the loggers is not still writing to the old log files folder.

Windows 7 has a wonderful security feature that can prevent programs from writing to certain locations in the file system, even if you are an administrator. If you had problems with TMM 2.0.3, then I expect that you will eventually have problems with earlier 2.x releases. You may try to turn off this security feature in Win 7 by doing the following:

Open control panel

search for "uac" (without quotes)

Select the topic for turning user account control off (you may have to select "Search windows help and support...")

Click on hyperlink to "open user account control settings.

Move slidebar to the bottom (Never Notify) and press OK.

Enthusiast

Re: Teradata Mapping Manager 2.0.3, error with LogFile permissions

Thanks.   You could call us "slow adopters" - we're running XP.  The error is that it it testing the LogFiles folder in the Install directory, not the My Documents directory.

2.0.2. is working fine, so far, but I've only had a brief look.

Teradata Employee

Re: Teradata Mapping Manager 2.0.3, error with LogFile permissions

Kindly verify the following things.

1. You should have only one file under install directory\bin\LogFiles

2. Open registry editor and let me know the string value of "ProductName" under  "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion"

3. Find attached test.txt with this post, download it, then change extension from txt to bat, run test.bat on your machine and let me know output.

Enthusiast

Re: Teradata Mapping Manager 2.0.3, error with LogFile permissions

Thankyou,

That helped identify the problem.

My "My Documents" folder is mapped to a shared network drive.   The install copied the Teradata Mapping Manager to this folder.

The folder check on startup is looking in "%userprofile%\My Documents\Teradata Mapping Manager".  My "userprofile" variable is set to my C:\Document and Settings....  which is not where the Teradata Mapping Manager folder was installed.

I have manually copied the folder from the network drive to my C drive and it now works.

I'll get our support guys to change my %userprofile% setting, but it may be wise for the Install and the startup Folder Check to use the same method for determining where "My Documents" is.

Thanks for your help.

Enthusiast

Re: Teradata Mapping Manager 2.0.3, error with LogFile permissions

P.S. From WikiPedia http://en.wikipedia.org/wiki/Environment_variable:

Many open source programs incorrectly use USERPROFILE for application settings in Windows - USERPROFILE should only be used in dialogs that allow user to choose between paths like Documents/Pictures/Downloads/Music, for programmatic purposes APPDATA (roaming), LOCALAPPDATA or PROGRAMDATA (shared between users) is used.

Teradata Employee

Re: Teradata Mapping Manager 2.0.3, error with LogFile permissions

Hi,

Kindly find attached text.txt and do the same thing one more time, download it then change extension from txt to bat.

Run test.bat and this time, it should show you the exact path of your document folder , which is mapped to a network drive.

Thanks & Regards

Mohsin Ali

Enthusiast

Re: Teradata Mapping Manager 2.0.3, error with LogFile permissions

Hi,

Well, it shows me "My Documents" on the shared file system, which is also mapped to a local "H:" Drive.  That looks OK.

However,  this appears to have nothing to do with the startup checks - It doesn't check this path:

1)  The folder check on startup is driven by the %userprofile% parameter.

2)  The error message on startup displayes that it is the Install Directory that had the issue, which is not the case.

The Install process and Startup Folder Checking are using different assumptions.  I'm that the profiles on my pc could be cleaned up, but "something ain't right" with the install.

I have a workaround for now, but I have a Teradata Mapping Manager folder in 3 different locations !

Thanks for your help.

Enthusiast

Re: Teradata Mapping Manager 2.0.3, error with LogFile permissions

The programmers found the problem. The problem is limited to the batch files that start the TMM Java program. If you are using TMM 2.0.3 and seeing this "Cannot crfeate log files under..." error message, then see the following instructions to fix the problem:

This problem can occur for any of the following reasons (and perhaps other reasons):

- My Documents folder is on a networked drive

- if you are out of disk space

- if you do not have permissions to write to this folder

- (unverified) non-English language PCs if the folder "My Documents" has a localized name.

(TMM 2.0.3 users only)

Close TMM, if open.

Copy the attached text files to "<TMM install path>\bin" folder. The following are the default folder paths:

   (32-bit Win XP and Win 7 users)  C:\Program Files\Teradata Mapping Manager\bin

   (64-bit Win 7 users)             C:\Program Files (x86)\Teradata Mapping Manager\bin

The attached text files need to be renamed to remove the "_.txt" file extension,

but there are 2 files with the same name already in the bin folder,

so the first step is to rename those existing files as follows:

   TMM_AppStart.bat       --> TMM_AppStart.bat.old

   run.bat                        --> run.bat.old

Now you can rename the text files that you just saved to the bin folder, as follows:

   TMM_AppStart.bat_.txt       --> TMM_AppStart.bat

   run.bat_.txt                        --> run.bat