Teradata Mapping Manager problem using double-byte language PC settings

Tools
Enthusiast

Teradata Mapping Manager problem using double-byte language PC settings

One of our new Korean TMM users was not able to import data representations into a newly created metadata repository. This appears to be the result of a bug in our script file processing on a Windows PC configured for the Korean language (may also be a similar problem for other double-byte language settings). We are working on a code fix but, for now, there is a workaround:

Prior to creating a new repository or migrating a repository (repository migration occurs when you install a new version of TMM that requires changes to the repository):

Close TMM, change your Windows regional language settings to US English ((WinXP) Start-> Control Panel-> Regional and Language Options-> Regional Options tab-> select “English (United States)” in top drop-down box) . Open TMM, migrate an existing repository and/or create new repository. Exit TMM. Change langauge setting back to your preferred langauge and TMM should work for all other functions.

We should have a fix that does not require the workaround in the next patch release, coming soon.