Update TeraGSS error

Tools
Enthusiast

Update TeraGSS error

When updating TearaGSS version, I got the error here:

Could not delete old version LCLIENT symbolic link.

the tdgssversion command shows:

The Teradata GSS Client available versions for nt-i386 are:
Note: An * denotes the current version.
13.00.00.00
13.10.00.03

there is no * mark here.

How can i remove the older gss and make the newer take effect?

Thanks.
Tags (1)
1 REPLY
Enthusiast

Re: Update TeraGSS error

I solved this issue. But i do not know which is the key point in the following steps. :P

Platform : win7 enterprise
TD:13.10.00.03

1. delete all key containing 13.00.00.00 value in regedit tool manually.

2. uninstall CLIV2, ICU, GSS from ctrl panel.

3. search 13.10.00.03 values in regedit tool, and delete the found ones.

4. re-install ICU, GSS, CLIV2 orderly.

5. delete the tdgssconfig.bin in the C:\Program Files\teradata\Teradata GSS\nt-i386\13.10.01.03\etc\ if exists.

6. run the run_tdgssconfig.bat in the C:\Program Files\teradata\Teradata GSS\nt-i386\13.10.01.03\bin to generate the tdgssconfig.bin

7. check the version info via tdgssversion to see:
The Teradata GSS Client available versions for nt-i386 are:
Note: An * denotes the current version.
13.10.01.03 *

8. use the tests command to verify.

after such steps, my bteq works.