tpump loading error

Tools
Enthusiast

tpump loading error

Below is my tpump script
------

.logtable b.tpumplogtable;
.LOGON a/b,passwd;

.BEGIN LOAD
ERRLIMIT 5
CHECKPOINT 50
SESSIONS 1
TENACITY 2
PACK 5
RATE 10
ERRORTABLE b.ET_TPUMP_LOG ;

.layout INSERTEMP3;
.field in_empno * varchar(10);
.field in_ename * varchar(30);
.field in_DeptNo * varchar(10);
.field in_salary * varchar(10);

.dml label insertemp3tpump
IGNORE DUPLICATE ROWS
IGNORE EXTRA ROWS;
insert into b.emp3(empno,ename,DeptNo,salary)
values(:in_empno,:in_ename,:in_DeptNo,:in_salary);

.dml label deleteemp1table
IGNORE DUPLICATE ROWS
IGNORE EXTRA ROWS;
delete from b.emp1 where empno=:in_empno;

.IMPORT INFILE /wrk/tmp/emptpump1.txt
LAYOUT INSERTEMP3
APPLY insertemp3tpump;

.IMPORT INFILE /wrk/tmp/emp1tpump.txt
LAYOUT INSERTEMP3
APPLY insertemp3tpump
APPLY deleteemp1table;

.END LOAD;
.logoff;

data in the mentioned two files is like:

2,RAMA,20,9000
7,SUJIT,10,10000
4,RANU,30,12000
9,HARI,10,13000
1,UMESH,30,14900

2 REPLIES
Enthusiast

Re: tpump loading error

**** 05:24:41 UTY8802 WARNING: Rate Monitoring turned off - database TPumpMacro does not
exist.
**** 05:24:41 UTY6608 Import 1 begins.
**** 05:24:41 UTY4015 Access module error '16' received during 'read' operation on record
number '0': 'Unexpected data format'
========================================================================
= =
= Logoff/Disconnect =
= =
========================================================================
**** 05:24:41 UTY6215 The restart log table has NOT been dropped.
**** 05:24:41 UTY6212 A successful disconnect was made from the RDBMS.
**** 05:24:41 UTY2410 Total processor time used = '0.335028 Seconds'
. Start : 05:24:39 - TUE JAN 18, 2011
. End : 05:24:41 - TUE JAN 18, 2011
. Highest return code encountered = '12'.
Teradata Employee

Re: tpump loading error

You are running TPump with data in VARTEXT (delimited) mode. You need to specify that in the TPump script and indicate the delimiter character.

Please refer to the TPump documentation for the proper syntax.

Hint: it will be something like:

.IMPORT INFILE FORMAT VARTEXT ','

-- SteveF