Mload Login Error

UDA
Enthusiast

Mload Login Error

Hi,

I am trying to write a simple mload script to load few records into an empty table. Below is the script that i have written

.logtable abclog;
.Logon tdpid/userid,pwd;

database dev_work;

Create table edwdev_ads_work.emp1
(
EmpNo Smallint NOT null,
Empname char(35)
) unique primary index(Empno);

.begin import mload tables emp1;
.layout Insfilelayout;
.field Empno * smallint;
.field Empname * char(35);
.dml label insertdml;
insert into emp1 (EmpNo,Empname) values(:Empno,:Empname);
.import infile insertfile format text layout Insfilelayout apply insertdml;
.end mload;
.logoff;

I m running this script from Unix using command $ mload < myscript.mload

it gives me an Error as below
UTY3403 Only one statement per line is allowed. Extra characters were detected
beginning in column '31'.
**** 18:36:03 UTY2410 Total processor time used = '0.01 Seconds'
. Start : 18:36:03 - MON MAY 26, 2008
. End : 18:36:03 - MON MAY 26, 2008
. Highest return code encountered = '8'.

i m able to login in interactive mode(giving tdpid/userid and then pwd).
I am not sure why i am not able to login by the above command? Please help
5 REPLIES
Teradata Employee

Re: Mload Login Error

If password contains characters other than letters, numbers, and underscore then it must be "quoted" when put in the LOGON statement text. Quotes are not needed when responding to a prompt, or when an application or a driver dialog sends the password as a separate field from the username.
Enthusiast

Re: Mload Login Error

Thanks Fred,

my password contains only characters and numbers but i tried making changes to .logon as suggested.

.logon tdpid/userid,"pwd";

but still the same error.

Regards,
Saurabh
SN
Enthusiast

Re: Mload Login Error

hi saurabh,

the script looks fine....as the error msg says, chk for any extra characters after end of any sql stmts in the script.

thx,
Enthusiast

Re: Mload Login Error

The problem is solved by converting windows file into unix format..

dos2unix filename;

this removes unwanted characters.
Enthusiast

Re: Mload Login Error

Hi

I am trying to MLOAD into a table using Mainframe. I am getting the same error. (UTY3403)

I tried adding quotes for the password field. But still I have the same problem. The query is fine and I am getting result when I hard code my username and password...any thoughts...??