problem in mload

UDA
Enthusiast

problem in mload

when I trying to run my mload scrip in command prompt it shows me error like

********2583 worktable missing for databse.tablename during mload*****
4 REPLIES
Enthusiast

Re: problem in mload

Can you try specifying worktables in your script and check if you get the same error message.I hope we can mentione worktable names explicitly in mload scripts.
Senior Apprentice

Re: problem in mload

Possible reasons might be:
- someone dropped the worktable
- you specified the wrong name during a restart
- a previous MLoad was cancelled without RELEASE MLOAD...

From the messages manual:
2583 %VSTR is missing for %DBID.%TVMID
during MLoad restart.
Explanation: WorkTable or Error table is missing
during restart.
Generated By: STPEBE
For Whom: User.
Remedy: Drop the existing worktable and error tables
of the MLoad job. If the error is diagnosed before the
end of the acquisition phase, issue the RELEASE
MLOAD statement on the MLoad target tables. Otherwise,
the target tables should be dropped. Finally,
restart the MLoad job.

Dieter
Enthusiast

Re: problem in mload

Make sure u have access to create table.
for grant create table execute following query.
grant create table on "Database Name " to "User Name".
Fan

Re: problem in mload

Make sure the table is not locked by previous mload.If it is then execute the following statements and Try running mload again.

drop table error_table1
drop table log_table
drop table work_table
drop table error_table2

release mload table_name