Deleted VP-System keeps on coming back in 'Teradata Systems' admin portlet

Viewpoint
Teradata Employee

Deleted VP-System keeps on coming back in 'Teradata Systems' admin portlet


Hello,

We have a PDK V13.03.00.05-b106 test system at our customer site.

When we try to delete a certain VP-system within the 'Teradata Systems' admin portlet
the VP-system can be deleted at first and it does disappear.

But as soon as we close and reopen the 'Teradata Systems' admin portlet the
deleted system is back like a 'Zombie'-System.

We deleted/killed the 'Zombie' VP-system many times but it keeps on coming back every time!

Does anybody have something like a silver bullet to kill that 'Zombie' VP-system once and for all?

regards
Marcus
4 REPLIES
Teradata Employee

Re: Deleted VP-System keeps on coming back in 'Teradata Systems' admin portlet

Marcus,

Are you performing the system deletion through the Viewpoint Admin screens under Teradata Systems and the "Delete System" prompt? Or are you attempting to do this programmatically? I ask because you mention the PDK version. If you are attempting this through the Admin menus, what version of Viewpoint are you running with?

Gary
Teradata Employee

Re: Deleted VP-System keeps on coming back in 'Teradata Systems' admin portlet

Hi Gary,

I am performing the system deletion through the Viewpoint Admin screens under Teradata Systems using the "Delete System" button.

The problem occurs on a test system running PDK V13.03.00.05-b106 at our customer site.

Marcus
Teradata Employee

Re: Deleted VP-System keeps on coming back in 'Teradata Systems' admin portlet

Marcos,

So I believe you are saying that this issue is with your Viewpoint PDK 13.03 development environment, not a Viewpoint standard operating environment. Our testing has not found any issues with system deletion with either so the recommendations for you are:

1) Check for errors in the log related to the deletion or a system or some permission denied message that would indicate a permissions issue

2) Reinstall your development environment because you may have corrupted something during your development/testing.
Enthusiast

Re: Deleted VP-System keeps on coming back in 'Teradata Systems' admin portlet

Looks like you have an TMSM environment. If this assumption is correct, then your 'deleted' system is still sending events through the TMSM Client. Unless you turn off the TMSM Client on this system, it will keep sending events to TMSM and when that happens, VP will continue to show this system, since the autoregister will recognize and add it as a component.
Atleast this is what I had to do to get the issue resolved.